Bug 1466781 - Missing href attributes in some REST entry points
Missing href attributes in some REST entry points
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
4.1.3.5
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ori Liel
Radim Hrazdil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 08:32 EDT by Christophe Fergeau
Modified: 2017-12-20 06:46 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:46:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81376 master POST Fix Hrefs For Inline Collections 2017-09-03 07:26 EDT

  None (edit)
Description Christophe Fergeau 2017-06-30 08:32:33 EDT
In /api/storagedomains, there is a <data_centers> node without href attributes:

<data_centers>
    <data_center id="00000001-0001-0001-0001-000000000311"/>
</data_centers>

There is a similar issue in /api/vms with the <hosts> node:

<hosts>
    <host id="7620720b-eb29-4905-b5e8-c9b00ddb1e47"/>
</hosts>
Comment 2 Ori Liel 2017-09-06 03:55:44 EDT
Patch posted: 

  https://gerrit.ovirt.org/#/c/81376/
Comment 3 Radim Hrazdil 2017-11-16 07:19:14 EST
Verified that all <data_center> nodes have href attribute. Version 4.2.0-0.0.master.20171108151837.gita7de53e.el7.centos.
Comment 4 Sandro Bonazzola 2017-12-20 06:46:32 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.