Bug 1466855 - Embedded ansible role fails to re-initialize after webui update
Embedded ansible role fails to re-initialize after webui update
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.8.1
Assigned To: Nick Carboni
luke couzens
ansible_embed:black
: ZStream
Depends On: 1465590
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 10:53 EDT by Satoe Imaishi
Modified: 2017-08-02 13:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.8.1.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1465590
Environment:
Last Closed: 2017-08-02 13:33:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Comment 2 Nick Carboni 2017-06-30 11:47:23 EDT
https://github.com/ManageIQ/manageiq/pull/15487
Comment 3 CFME Bot 2017-06-30 14:01:14 EDT
New commit detected on ManageIQ/manageiq/fine:
https://github.com/ManageIQ/manageiq/commit/43f3b266b27625d18dfaa76c7d184c8427c7d57c

commit 43f3b266b27625d18dfaa76c7d184c8427c7d57c
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Fri Jun 30 11:25:19 2017 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Fri Jun 30 11:25:19 2017 -0400

    Run the setup playbook if we see that an upgrade has happened
    
    The playbook needs to run on upgrades and ansible tower will refuse
    to start if it isn't.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1466855

 lib/embedded_ansible.rb           | 17 ++++++++++++++++-
 spec/lib/embedded_ansible_spec.rb | 34 +++++++++++++++++++++++++++++++++-
 2 files changed, 49 insertions(+), 2 deletions(-)
Comment 4 luke couzens 2017-07-12 19:42:41 EDT
Verified in 5.8.1.2
Comment 6 errata-xmlrpc 2017-08-02 13:33:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:1758

Note You need to log in before you can comment on or make changes to this bug.