Bug 1466867 - Docker doesn't start with error "can't create unix socket /var/run/docker.sock: is a directory"
Docker doesn't start with error "can't create unix socket /var/run/docker.soc...
Status: CLOSED DUPLICATE of bug 1466479
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Antonio Murdaca
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks: 1186913
  Show dependency treegraph
 
Reported: 2017-06-30 11:25 EDT by Alexis Solanas
Modified: 2017-11-27 03:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-27 03:39:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexis Solanas 2017-06-30 11:25:53 EDT
Description of problem:

 docker start fails with the error message: 
  
   level=fatal msg="can't create unix socket /var/run/docker.sock: is a directory"

Version-Release number of selected component (if applicable):

 docker-1.12.6-28

How reproducible:

 Unknown, it happens randomly when restarting docker

Steps to Reproduce:

1.
2.
3.

Actual results:

 docker fails to start

Expected results:

 docker starts normally

Additional info:

 This is being tracked by the following upstream issue:

  "can't create unix socket /var/run/docker.sock: is a directory #30348"
   https://github.com/moby/moby/issues/30348
Comment 2 Daniel Walsh 2017-07-02 06:07:30 EDT
How is the container being started, is it autostarted by docker?
Comment 3 Nitin 2017-07-03 11:16:12 EDT
This issue i observed, when i do automated playbook upgrade. 
After the draining of all pods and restart of docker service.
Comment 7 Alexis Solanas 2017-11-27 03:39:37 EST

*** This bug has been marked as a duplicate of bug 1466479 ***

Note You need to log in before you can comment on or make changes to this bug.