Bug 1466880 - [Intel OSP13] Identify and list Health/State of RSD resources
[Intel OSP13] Identify and list Health/State of RSD resources
Status: CLOSED DUPLICATE of bug 1466874
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
13.0 (Queens)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
mlammon
: FutureFeature
Depends On:
Blocks: epic-rsd 1419948 1422243
  Show dependency treegraph
 
Reported: 2017-06-30 11:56 EDT by Krish Raghuram
Modified: 2017-10-20 12:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-20 06:15:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krish Raghuram 2017-06-30 11:56:11 EDT
Description of feature:
Each RSD asset has different Health (configuration error, correctible or uncorrectable error, Temperature trip) and State information (presence detected, removed, power state and so on).
The appropriate RedHat OSP modules should be able to identify and list the above Health/State types for every RSD resource (Server, Storage, Compute, Memory, FPGAs) when needed

Version-Release number of selected component (if applicable):
OpenStack Ironic version (or others potentially) in OpenStack Queens release

2. Business Justification:
  a) Why is this feature needed?
     RSD is a new architecture that realizes an agile infrastructure where the hardware resources can be pooled according to application needs. It also enables a more easily scaled infrastructure, so CPU, memory, network and storage resources can be added as needed, without the need to do complete replacements of nodes
  b) What hardware does this enable?
   New platforms based on RSD architecture
  c) Is this hardware on-board in a system (eg, LOM) or an add-on card? 
  RSD nodes are disaggregated (CPU, memory, storage, accelerators etc.)
  d) Business impact? N/A
  
  e) Other business drivers: N/A

3. Primary contact at Partner, email, phone (chat)
   Priyank Durugkar - priyank.durugkar@intel.com

4. Expected results:
- DC admin lists available RSD nodes 
- Admin lists the health/state of each node and resources within each node
- Admin also lists available RSD resources and health/state of each

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-30 11:56:18 EDT
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.
Comment 2 Krish Raghuram 2017-09-21 10:52:02 EDT
This work is automatically covered in the upstream work being done for BZ# 1466873 and 1466874, which are high priority for Queens
Comment 3 Ramon Acedo 2017-10-20 06:15:42 EDT
Hi Krish, if pythonrsd-client is capable of identifying and listing Health/State of RSD resources, I suggest we mark this BZ as a duplicate of BZ#1466874.

*** This bug has been marked as a duplicate of bug 1466874 ***
Comment 4 Krish Raghuram 2017-10-20 12:40:33 EDT
(In reply to Ramon Acedo from comment #3)
> Hi Krish, if pythonrsd-client is capable of identifying and listing
> Health/State of RSD resources, I suggest we mark this BZ as a duplicate of
> BZ#1466874.
> 
> *** This bug has been marked as a duplicate of bug 1466874 ***

Agreed

Note You need to log in before you can comment on or make changes to this bug.