Bug 1466907 - Liveinstaller desktop launcher isn't marked as executable on Mate-Compiz livespin rc-1.1
Liveinstaller desktop launcher isn't marked as executable on Mate-Compiz live...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 1466534 (view as bug list)
Depends On:
Blocks: F26FinalFreezeException
  Show dependency treegraph
 
Reported: 2017-06-30 13:27 EDT by Wolfgang Ulbrich
Modified: 2017-07-02 17:07 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-02 17:07:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Ulbrich 2017-06-30 13:27:15 EDT
Description of problem:
For some reasons the anaconda desktop launcher isn't marked as executable on Mate-Compiz livespin rc-1.1, and no icon will display.
Clicking on it produce a a popup which asked you to 'mark a untrusted launcher as trusted'.
Choosing 'yes' make the icon visible and you can use the installer.

This is the same as 
chmod +x /home/liveuser/Desktop/liveinst.desktop

I tested this with that compose 
Fedora-MATE_Compiz-Live-x86_64-26-1.1.iso          2017-06-30 09:03

Version-Release number of selected component (if applicable):


How reproducible:
running the Fedora-MATE_Compiz-Live-x86_64-26-1.1.iso.
Comment 1 Wolfgang Ulbrich 2017-06-30 13:28:27 EDT
I forgot to say that i filled out a kickstart PR.
https://pagure.io/fedora-kickstarts/pull-request/254
Comment 2 Fedora Blocker Bugs Application 2017-06-30 13:37:30 EDT
Proposed as a Freeze Exception for 26-final by Fedora user raveit65 using the blocker tracking app because:

 Anaconda desktop launcher isn't executable on Mate-Compiz spin.
chmod +x /home/liveuser/Desktop/liveinst.desktop
fixes that, but this is a bit ugly for a fedora product.
This PR fixed that at kickstart repo.
I am happy to test next compose with that change.
Comment 3 Adam Williamson 2017-06-30 13:39:48 EDT
+1 FE.
Comment 4 Adam Williamson 2017-06-30 13:44:02 EDT
Assigning to spin-kickstarts but to a MATE maintainer.
Comment 5 Dennis Gilmore 2017-06-30 14:16:55 EDT
+1 FE
Comment 6 Kevin Fenzi 2017-06-30 15:20:00 EDT
+1 FE
Comment 7 Adam Williamson 2017-06-30 16:01:45 EDT
That's enough votes, accepting.
Comment 8 Matthew Miller 2017-07-01 11:46:51 EDT
Looks like the PR for this is merged...
Comment 9 Wolfgang Ulbrich 2017-07-02 01:14:20 EDT
*** Bug 1466534 has been marked as a duplicate of this bug. ***
Comment 10 Wolfgang Ulbrich 2017-07-02 17:07:07 EDT
I can confirm that the issue is fixed with RC 1.3 compose.
The installer desktop launcher is executable, the icon is visible, and installation works like a charm.
Thanks for your votes and quick reaction.

Note You need to log in before you can comment on or make changes to this bug.