This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1466919 - Sync Plans not fully executing
Sync Plans not fully executing
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.2.10
Unspecified Unspecified
high Severity high (vote)
: 6.2.12
: --
Assigned To: satellite6-bugs
Renzo Nuccitelli
: FieldEngineering, PrioBumpField, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 14:17 EDT by Dylan Gross
Modified: 2017-10-16 21:33 EDT (History)
16 users (show)

See Also:
Fixed In Version: pulp-2.8.7.15-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1480347 (view as bug list)
Environment:
Last Closed: 2017-09-25 14:59:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 2903 High CLOSED - CURRENTRELEASE Process Recycling feature causes HTTP event notifier to be unreliable 2017-08-15 10:31 EDT

  None (edit)
Description Dylan Gross 2017-06-30 14:17:50 EDT
Description of problem:

During either an upgrade, or during a lapse in subscriptions due to a renewal, the sync_plans for Red Hat Satellite stopped communicating with foreman. 

This case is a spin-off from BZ#1430836 which was determined to be a different issue relating mostly to invalid certificates.

This affected all sync plans on the Satellite, and even newly created sync plans fail to execute.


Version-Release number of selected component (if applicable):

  Currently Red Hat Satellite 6.2.10


How reproducible:   Unknown

Actual results:

   The sync status in the UI never gets updated after the sync plans are expected to run.   There are no foreman tasks being created as a result of a sync plan execution.

Expected results:

   Sync plans run on schedule, create the foreman tasks, and update the sync status page with results.

Additional info:

  - Not using deferred (lazy) sync.
  - If a single repo is told to sync manually, it succeeds.
  - If the sync plan is executed manually (via bulk task) on sync plan page, it succeeds.
Comment 5 pulp-infra@redhat.com 2017-07-13 17:02:45 EDT
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 6 pulp-infra@redhat.com 2017-07-13 17:02:49 EDT
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.
Comment 7 pulp-infra@redhat.com 2017-07-14 13:31:44 EDT
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.
Comment 8 pulp-infra@redhat.com 2017-07-14 14:34:38 EDT
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.
Comment 9 pulp-infra@redhat.com 2017-07-14 15:01:46 EDT
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.
Comment 12 pulp-infra@redhat.com 2017-07-31 10:46:27 EDT
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.
Comment 15 pulp-infra@redhat.com 2017-08-15 10:31:36 EDT
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 18 Renzo Nuccitelli 2017-08-31 10:46:33 EDT
I tried to reproduce on 6.2.12 with pulp-server-2.8.7.15-1.el7sat.noarch but sync plan worked all the time. So I am moving this to VERIFIED.
Comment 21 errata-xmlrpc 2017-09-25 14:59:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803

Note You need to log in before you can comment on or make changes to this bug.