Bug 1466985 - Slow errata patching while trying to patch a number of consumers and errata at the same time
Slow errata patching while trying to patch a number of consumers and errata a...
Status: CLOSED DUPLICATE of bug 1288152
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.2.10
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-01 01:08 EDT by Hao Chang Yu
Modified: 2017-07-26 15:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-03 10:02:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 1462 High CLOSED - CURRENTRELEASE Errata Install to Content Host takes too long and doesn't scale well 2017-07-01 08:05 EDT

  None (edit)
Description Hao Chang Yu 2017-07-01 01:08:13 EDT
Description of problem:
There is a calculation in pulp_rpm plugin which will translate an erratum to rpms that are applicable by the consumer. This calculation started to give burden to the Satellite when user trying to patch a number of errata to large number of consumers. Customer complain that the Satellite is basically unresponsive at that time. Some slow queries were logged in the mongo log file, such as [1]. 

There is a upstream bug for it which has been fixed since upstream pulp 2.8.5. The fix is to remove the errata translation from pulp and let the client, katello-agent, yum to figure out the packages to be installed.

https://pulp.plan.io/issues/1462

I am not sure why downstream didn't include this fix.

[1]
2017-06-30T12:43:38.312+1000 [conn18955] warning: log line attempted (817k) over max size (10k), printing beginning and end ... query pulp_database.units_rpm query: { $query: { epoch: "0", version: "3.10.0", name: "kernel-headers", release: "514.16.1.el7", _id: { $in: [ "21cb6969-f33c-436d-9633-3feff7f55a5d", "9b2eea91-91df-4a1f-bde0-94474e91e96c", "b2ca0095-70fe-4825-97b0-d9fea9f6dbef", "fecffd36-ba42-4cfe-a4c8-c6c82e706d05", "65ac0eec-bcdb-4ffb-af97-be3ca0c5c2be", "5f6c8f80-0f9a-42a9-bb6f-7dd687e2e188", "a86c9c67-6c55-4c10-ab41-756b84800974", "a4129aec-8dc4-45fc-82e0-fc8f467fd20c", "f9db6101-6957-43e4-9074-380c46b0ce6d", "c839b7cf-5aba-46f2-ba32-b25c9d1a28c2", "adab81b1-45ca-4407-8a41-f36641a5ace3", "5ab785f0-5cdd-4da0-8838-9c500aba0130", "85f70fb1-6e17-43eb-b046-6c3c5dcb946d", "aaae67dc-4070-4da2-97a3-bfabe5dfb5f8", "27986784-856b-48c4-a933-ecf7321209d5", "346e7a89-9870-44bd-8f65-a57bb88a3246", "39df3c11-80cd-417e-9d50-69b1210c85d4", "5b700953-6a6f-4175-931f-af3fa12e47f6", "b7bfc79b-b114-46b7-8d06-f229d946fe87", "04604262-4fb2-4012-810d-d370770233bb", "6052e988-0cc8-45a8-9ca0-2e80449904ce", "30796ad4-e72a-4d80-afd9-cc75345f69d8", "001280f1-5cb1-479a-8f20-d2eec3434c54", "e9f278a9-6a2a-4491-a7d5-43cb4623ec74", "6714b7e0-d93d-4c4d-a08f-f6413b9b44c5", "7108c833-af3e-4941-b4e1-286d109ace70", "692170b4-e1d3-459f-b8a5-a5439b7c83b6", "bc6ed218-1550-4024-aa3a-964270587e8a", "e3db780c-0eae-4bee-88a1-131243068dc1", "fd8a14c0-6fe7-40d4-b8b5-a9edb5680490", "b5d1280d-a675-4fa9-a676-d307c5baf748", "7df26a70-441d-40b3-ae81-d80537ca395a", "eeb18551-f8f8-4271-b745-973e16512a9c", "25c773fd-8b4f-4406-9b9e-b020b3a29d4e", "8e612649-6f36-4377-8729-f19e31af5409", "6d0777ae-b767-43ba-80ca-0f94901e7b96", "65a17d06-6467-4d79-aca3-588d5016d626", "5184d2a1-c0e7-4533-afe6-158bebc973c1", "1eb90414-6b7f-4cb1-b643-1e771ead77b7", "55079ad6-803e-493d-a83d-08b8e5ab07d9", "6195414d-ffeb-4181-aa37-d2d0c20d8c9c", "411cceef-0bfd-435f-b285-ddf188796123", "2a4ec50c-efaa-4fe1-9d48-17901f05ddeb", "901e3587-8d45-4fac-b032-73b122780ca8", "e7f1c786-ab58-4308-8a4d-b220d80b4493", "292ed0ac-ec08-4819-aa8b-68654710aee4", "d53303b6-34e3-4155-9195-f39077472988", "385f3440-fc13-4164-a3a0-ee5caa878af3", "74d1a426-7414-43c9-9c08-cc6769d9465c", "51d4216a-0ce5-43fa-86c5-bed69d5ea77b", "b9e15471-9b3d-47fb-903a-4c5db139631b", "4c6643b9-79bd-4bf8-b0ce-cd6127928675", "dfa2f386-3aa8-40b6-a20b-286261ec6def", "b05bc840-bd18-4f72-81d6-9a16cb5a4abc", "6123ac13-5625-4e53-93c2-57377531693b", "3f712380-b5ed-43f3-be27-9453819bf995", "a2d48dd0-451b-491f-a0a0-0d74a9f530d0", "5bfe7697-2ccb-43d5-94f1-fb6f67e79e72", "abc1b0be-30fa-44e7-bfc1-ab254849709a", "78b75f60-0d73-4042-9658-f9e57da54dea", "c3c1f172-62ee-48b0-a147-b3329e8cd609", "f48fe26a-9e34-4f42-aa7a-e5e506d56406", "8d9d4d2b-106d-4c7f-a15f-5b98c17dab2e", "0fc5adc6-8c72-4e82-8d5d-ba52193cdcc9", "7a567756-f322-4f10-85df-3e488343f466", "d03f6a11-6d8b-4b43-875c-7abfea4c7f71", "52e0b708-bd8e-41db-b91c-0001eccd8892", "d40893f9-2bdb-46ac-a514-d2dbe44818e3", "ce192100-94b5-4ba8-a5d4-e3bf4bfe55ce", "fbf8ccc0-43d7-411e-9dce-45ff2e93f722", "7d5f2445-90cd-4f19-ab5b-29cd50f68003", "67cbbc44-eec3-4d28-bdf7-71c1edcb6b31", "467b3c9b-d6d0-4a6e-89f5-70b01da10d15", "43051e29-adbc-4bd7-9fca-815ce8b4a1e8", "efe84713-f1a9-4a8b-964c-a4dab2a828cf", "de6cdfea-97cf-4503-8b8a-1ece609ea3b7", "815026ce-bcc3-40bf-b24e-1bb7c995b49c", "f6182e3f-6496-45b9-9ba1-838899b43f31", "62f0c092-6e7a-436c-ba59-7c784bfc963e", "745b564c-1ef2-4d19-887a-91d530ae83bb", "e7e5637d-f6c4-4fde-9b9b-88280f62f6bb", "6165ff19-73a5-499d-91e6-36ca8 .......... 6d", "0ee46368-1380-40c5-a8af-81f20f3005a9", "1b0abf50-7e82-433c-b801-72281967c056", "e9cfa154-def8-4e99-9caa-26866d984931", "afe1475a-e277-41ee-aef9-983e53cf3eb6", "ee2f319d-d070-4376-895d-778060ef399c", "19056b12-1f2e-4337-a9b3-96016783fcf6", "974c6451-4732-4f26-ba18-a3d00c4f3ec8", "04debb29-4cf2-434c-9a7d-06d69ceacca6", "bbce944d-a0d7-448b-8e53-739256ae0e94", "2c39e833-3532-4fbf-b94a-c6b517130796", "ffd3ebd5-841a-4ba1-8f77-cefd57bb35f5", "f1b75935-b6e9-41d1-98d1-71935ea00715", "88c67e09-3c84-4980-8498-bf6e01312b26", "57a8af78-b11d-4bd4-a0f2-bb5d1e3e3c20", "29fcaa81-0a4a-4e89-8116-df43ec7055aa", "b9c6f376-b11c-4c9a-820d-1e7d01c20b90", "df794d3d-29ec-4cb7-8b81-2ea0ad118c5c", "2223324f-2ef9-4b2b-a808-707e8cdd337a", "5df8154c-b859-4d13-9e25-e695503421da", "e40a760c-70fe-42cb-90fc-a836f5777f2f", "b023f47a-f83e-4cba-b4a1-fa5d92a18345", "56079dc5-83c1-4195-8df8-e873347b4245", "75e8fcdf-ec30-42ac-9219-25b471e95632", "d2c4af56-7daa-4f47-aa8c-70ac73276843", "8f491e6d-f551-4b5c-a5e9-9e5a58fd3a2d", "c8aa1e36-d8e2-4680-b694-5aa4660a8e4d", "c6fe0eaf-c942-4caa-83c1-44986a122e1a", "87a75a6c-b89e-4263-b2e7-e023d22ae1b3", "4fe4e5b6-0514-4beb-8fe4-19641db44526", "a974add4-6127-4e28-8e08-e7b9b3a591e3", "babd2b72-1720-4b6e-aaca-6ab493e2e01c", "69596866-9646-4ad2-a54f-98fa68a63e66", "efff83f4-a19f-4afc-bd62-180a7bc080d4", "ba0a9e78-410f-4c6e-a637-a8cfdc71c51e", "53c9241d-bdd8-4cee-94ac-c81083604fba", "52d24320-223c-4f15-a3eb-85ebd8f4e2db", "74180b91-d134-4a6d-b3ac-49a4d667848c", "81fcc9f9-5d94-4210-9f8b-dccf147546a3", "c17eda66-0d80-4ad4-af75-b735640edf30", "1d197163-2305-464e-852d-c517ce41ae84", "1823f125-5ea2-45f7-8d9d-71d0a32b4aa0", "4fb5641f-0d1e-45aa-8938-9a084c64c632", "622a26f4-aa12-43b9-8449-fe86df819f02", "6bee29b1-23b0-4ead-aa4b-373db37b4b59", "b07b5ce4-188e-4eb9-823b-1e192e317fb2", "a67e7284-1fac-4832-8a6a-d7e450d34b85", "11b81def-918f-4b0a-bf0f-4d296a2f67d3", "ef3ffdb9-2df0-4de3-b023-8b9c70eaa72e", "d2b777e3-1bef-41bd-a962-1ff980b761a2", "e10595d4-7815-459b-a048-69e5fabc33f3", "77d86f0e-c245-4d3d-aeca-10f55bad716b", "ee490e3b-1f1b-46c4-849c-24d8daf92ec6", "2085e1cd-a253-4c65-b305-264da9a15bf3", "254077c7-179d-4d3f-a5da-808fb67c0df8", "2deb748f-c124-4e8c-9682-b7f9b7e7f94d", "2f33a005-06e2-4118-bf2d-740bd98f4c86", "67436f22-b780-46e8-a654-94b6c25b928a", "d188fc53-9cfe-42ac-bc4f-b74671e15a7c", "63e33687-dba8-4519-8abe-b2b5d20dce11", "7c817426-2319-4910-9f2a-60c3170ba779", "2ae78284-f4e9-4af9-8f7f-e96d9675e57d", "50141a2b-6b68-475a-9799-270deeed9f8a", "217ab9a6-be42-455d-895a-805550d4a95a", "a101f5db-cb59-47d0-9822-dbcfaa2242f5", "ab0457a0-ef91-4079-9f27-1a15a0815690", "1d58a93e-7f88-464b-98b0-3811d6842602", "b85128b9-d49c-4522-a8e2-33ed308a3d73", "37cace6f-74f3-42c0-bb23-102a7f6b1425", "c5aff104-42fa-43bd-bcac-df693d82ea42", "376505d5-d176-411b-83c2-bdf63dc9697e", "97395246-325d-493f-8f13-0e00b0c449f2", "789f44ec-4bfc-43dd-9d9a-eb140a3326c9", "fda9b591-2895-4cac-a3bb-30771947d57b", "8f672d6e-bae8-472c-9609-69108a6e6379", "3540d855-8a87-435b-ab7e-a72ba0409a49", "507ce777-fba0-4212-bb41-0ef74821d1ce", "ad400e78-f97f-4277-8ff4-701a06ef76c8", "d57cbc55-ddec-49b3-9ce9-19f04d749d5a", "5239a7ab-2565-4e89-85b2-f8d9d5f42c6c" ] }, arch: "x86_64" }, $orderby: { _id: 1 } } planSummary: IXSCAN { name: 1, epoch: 1, version: 1, release: 1, arch: 1, checksumtype: 1, checksum: 1 } ntoreturn:0 ntoskip:0 keyUpdates:0 numYields:0 locks(micros) r:102014 nreturned:0 reslen:20 102ms
Comment 1 David Davis 2017-07-01 08:02:29 EDT
I noticed this comment:

https://bugzilla.redhat.com/show_bug.cgi?id=1288152#c34
Comment 2 pulp-infra@redhat.com 2017-07-01 08:05:31 EDT
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 3 pulp-infra@redhat.com 2017-07-01 08:05:34 EDT
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.
Comment 4 pulp-infra@redhat.com 2017-07-01 08:35:42 EDT
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.
Comment 5 David Davis 2017-07-03 10:02:57 EDT
Confirmed with @jsherrill that this won't be fixed in 6.2. For 6.3, see https://bugzilla.redhat.com/show_bug.cgi?id=1288152.

*** This bug has been marked as a duplicate of bug 1288152 ***

Note You need to log in before you can comment on or make changes to this bug.