This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1466989 - System semi-brick on Fedora Boot [NEEDINFO]
System semi-brick on Fedora Boot
Status: NEW
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
25
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-01 03:11 EDT by Traace
Modified: 2017-07-12 06:37 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jkonecny: needinfo? (xxtraacexx)


Attachments (Terms of Use)

  None (edit)
Description Traace 2017-07-01 03:11:46 EDT
Description of problem:


Version-Release number of selected component (if applicable): Fedora Spin 25 KDE


How reproducible: Just install it with "bios boot" on a Ryzen System


Steps to Reproduce:
1. Install Fedora with bios boot partition
2. Reboot to Grub

Actual results: The System boots into Grub. But after selection of Fedora it says that "the Hardware is not compatible" then the screen stays black and the fans are go up to 100% RPM, a reset doesn't work a, full power off/on cycle is needed to bring the screen back. But that doesn't fix Fedora.

Systems like openSUSE are working fine with the same partition configuration.

Expected results: A proper Boot


Additional info: I tried to reinstall it a couple of times but its the same issue. Also the "Component" selection on this Website is very confusing for cases like this.

Hardware:
CPU: AMD Ryzen 1600
MB: Asus PRIME B350-PLUS
Comment 1 Kevin Fenzi 2017-07-01 09:52:12 EDT
This may be a kernel issue. Moving to that component. 

Some things to try to gather more data: 

* Try the latest live respin (This is the release fedora + all updates, including new kernel): http://tinyurl.com/Live-respins2

* Try the latest nightly Fedora 26 prerelease compose: 
http://dl.fedoraproject.org/pub/fedora/linux/development/26/Spins/x86_64/iso/Fedora-KDE-Live-x86_64-26-20170630.n.0.iso
Comment 2 Traace 2017-07-03 05:17:02 EDT
We tried the newer spins, they boot up just fine via USB. However it is impossible to finish the install this time.

Steps to Reproduce(Make sure u have a GPT-Disk with just a single NTFS partiton on it and some free space after that):

1. Boot Fedora Spin Live
2. Start the Installer
3. Pick the HDD with the single NTFS partition
4. Try to create a /boot or /boot/efi partition

Actual results: The Installer throws errors, the partiton will not get created. When we click the "more information" field right next to the error message it just gives a blank window without any detailed info at all.

Expected results: A creation of a /boot or /boot/efi partition on this healthy hdd like it should be and a proper error message if something goes wrong.


Additional info: We tried a couple of reboots and installer restarts.



We have many ESXi Racks and some VMs work well with fedora server too. But Desktop Linux still feels a bit more painful that it should be.
Comment 3 Peter Robinson 2017-07-03 05:27:22 EDT
This is installer, not kernel, setting anaconda but might be a different component

> We have many ESXi Racks and some VMs work well with fedora server too. But
> Desktop Linux still feels a bit more painful that it should be.

It's the same installer, possibly try the F-26 Release candidate and see if that installer works any better.
Comment 4 Jiri Konecny 2017-07-04 03:28:08 EDT
Hello Traace,

Could you please provides logs from the installation. You can find them in /tmp/ directory in the installation environment. When the error occurs you can switch to tty and grab the logs from there.

Thanks you

Note You need to log in before you can comment on or make changes to this bug.