Bug 1467051 - Mistral plan fail to update while performing minor update
Mistral plan fail to update while performing minor update
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-mistral (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: RHOS Maint
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-02 05:37 EDT by cshastri
Modified: 2017-07-09 03:19 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-09 03:19:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3101431 None None None 2017-07-02 10:00 EDT

  None (edit)
Description cshastri 2017-07-02 05:37:36 EDT
Description of problem:
While doing minor update of OSP10, mistral plans are failing to upload with error "string indices must be integers"

Version-Release number of selected component (if applicable):
OSP10

How reproducible:
Always


Steps to Reproduce:
1. Run 'openstack overcloud deploy --update-plan-only --templates ...' referring to https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/upgrading_red_hat_openstack_platform/sect-updating_the_environment#sect-Updating_the_Overcloud
 
2. Command fails to run with "string indices must be integers".

Actual results:
Plan fails to update.

Expected results:
Plan should get updated

Additional info:

Mistral packages on undercloud:

openstack-mistral-api-3.0.2-11.el7ost.noarch                
openstack-mistral-common-3.0.2-11.el7ost.noarch             
openstack-mistral-engine-3.0.2-11.el7ost.noarch             
openstack-mistral-executor-3.0.2-11.el7ost.noarch         
puppet-mistral-9.5.0-1.el7ost.noarch                        
python-mistralclient-2.1.2-1.el7ost.noarch               
python-openstack-mistral-3.0.2-11.el7ost.noarch

Note You need to log in before you can comment on or make changes to this bug.