Bug 1467085 - SELinux is preventing slick-greeter from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.
SELinux is preventing slick-greeter from 'read' accesses on the lnk_file /var...
Status: CLOSED DUPLICATE of bug 1467036
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:84772ed8b9919571ce7c75a69f7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-02 11:44 EDT by Heiko Adams
Modified: 2017-07-08 14:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-08 14:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2017-07-02 11:44:58 EDT
Description of problem:
Unlocking a session
SELinux is preventing slick-greeter from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If sie denken, dass es slick-greeter standardmäßig erlaubt sein sollte, read Zugriff auf machine-id lnk_file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
allow this access for now by executing:
# ausearch -c 'slick-greeter' --raw | audit2allow -M my-slickgreeter
# semodule -X 300 -i my-slickgreeter.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                /var/lib/dbus/machine-id [ lnk_file ]
Source                        slick-greeter
Source Path                   slick-greeter
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-259.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.8-300.fc26.x86_64 #1 SMP Thu
                              Jun 29 20:09:48 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-07-02 16:03:42 CEST
Last Seen                     2017-07-02 16:03:42 CEST
Local ID                      e9102c9c-aa37-4199-a812-928eedc37cc3

Raw Audit Messages
type=AVC msg=audit(1499004222.163:1785): avc:  denied  { read } for  pid=8044 comm="slick-greeter" name="machine-id" dev="dm-0" ino=3145731 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: slick-greeter,xdm_t,system_dbusd_var_lib_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64
type:           libreport
Comment 1 Karl Hastings 2017-07-08 14:52:08 EDT

*** This bug has been marked as a duplicate of bug 1467036 ***

Note You need to log in before you can comment on or make changes to this bug.