Bug 1467107 - Default configuration does not seem to work
Summary: Default configuration does not seem to work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apt-cacher-ng
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kenjiro Nakayama
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-02 22:52 UTC by Tim Coote
Modified: 2017-07-23 18:49 UTC (History)
1 user (show)

Fixed In Version: apt-cacher-ng-3-1.fc24 apt-cacher-ng-3-1.fc26 apt-cacher-ng-3-1.fc25 apt-cacher-ng-3-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-17 01:49:14 UTC


Attachments (Terms of Use)

Description Tim Coote 2017-07-02 22:52:30 UTC
Description of problem:
out of the box, the apt-cacher-ng service does not seem to do anything. The upstream package has a configuration file: /etc/apt-cache-ng/acng.conf, which is not in the rpm. Inter alia, this means that packages don't seem to be cached and the log files are in /var/tmp/apt-cacher-ng.{err,log}

Dropping in the default acng.conf from upstream seems to make this work.

It could be that I'm not exercising an expected usecase, but I've not found any documentation to help understand where the config file's gone.  I'm trying to use apt-cache-ng to cache the packages downloaded for build a raspberrypi image from (http://bit.ly/2uelq0D). 


Version-Release number of selected component (if applicable):
apt-cacher-ng-0.9.0-1.fc24.x86_64 (on f25)

How reproducible:


Steps to Reproduce:
1. on f25 box, clone the repo http://bit.ly/2uelq0D
2. ensure that apt-cacher-ng and any other dependencies are installed and the service is running
3. cd pi-gen, add in the cache to config:
IMG_NAME='Raspian'

APT_PROXY='http://<ip to this host>:3142'
4. ./build-docker.sh

Actual results:
The raspberry pi images are built, but the .deb packages are not cached in /var/cache/apt-cacher-ng


Expected results:
The raspberry pi images are built and the .deb packages are cached in: /var/cache/apt-cacher-ng/{archive.raspberrypi.org,mirrordirector.raspbian.org}


Additional info:
Dropping in default acng.conf (eg: http://bit.ly/2tGi4Xp) into /etc/apt-cacher-ng/, causes the expected behaviour.
afaict, the configuration file disappeared between v 0.8.3 and 0.8.8, but it's still in the upstream code. I do not see how this rpm has worked for some time (but I could be wrong)

Comment 1 Fedora Update System 2017-07-06 08:29:59 UTC
apt-cacher-ng-3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5ee6ce91fa

Comment 2 Kenjiro Nakayama 2017-07-06 09:39:46 UTC
Thank you so much for the report, Tim. I fixed and built the packages. If you like, you can test it from here:

f26 https://bodhi.fedoraproject.org/updates/FEDORA-2017-5ee6ce91fa
f25 https://bodhi.fedoraproject.org/updates/FEDORA-2017-c252ad0237
f24 https://bodhi.fedoraproject.org/updates/FEDORA-2017-3ac2f958d3
epel7 https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5d0a7f18cc

Comment 3 Fedora Update System 2017-07-06 18:23:27 UTC
apt-cacher-ng-3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5ee6ce91fa

Comment 4 Fedora Update System 2017-07-07 07:49:17 UTC
apt-cacher-ng-3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5d0a7f18cc

Comment 5 Fedora Update System 2017-07-07 09:05:20 UTC
apt-cacher-ng-3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c252ad0237

Comment 6 Fedora Update System 2017-07-07 09:05:36 UTC
apt-cacher-ng-3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3ac2f958d3

Comment 7 Tim Coote 2017-07-07 09:24:49 UTC
(In reply to Kenjiro Nakayama from comment #2)
> Thank you so much for the report, Tim. I fixed and built the packages. If
> you like, you can test it from here:
> 
> f26 https://bodhi.fedoraproject.org/updates/FEDORA-2017-5ee6ce91fa
> f25 https://bodhi.fedoraproject.org/updates/FEDORA-2017-c252ad0237
> f24 https://bodhi.fedoraproject.org/updates/FEDORA-2017-3ac2f958d3
> epel7 https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5d0a7f18cc

afaict, the f25 package seems to be working. I'll keep reviewing.  I note that the listening port is commented out in /etc/apr-cacher-ng/acng.conf, but the service listens on the expected port in any case.

Is there a smoke test to confirm that rpm's install all relevant config files, or to run the cache against some specific urls /mirrors to confirm that it's doing its job? I can see that such tests could be flakey as they may include external urls.

There do seem to be a few noise items in the build logs (missing symlinks that look like they're debian specific), and even some Errors, which I'd have thought could fail the build.

Comment 8 Fedora Update System 2017-07-17 01:49:14 UTC
apt-cacher-ng-3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Kenjiro Nakayama 2017-07-17 02:23:04 UTC
> afaict, the f25 package seems to be working. I'll keep reviewing.  I note that the listening port is commented out in /etc/apr-cacher-ng/acng.conf, but the service listens on the expected port in any case.

Yes, Port:3142 could be used by default without the configuration. 

FYI regarding another config, when I tested apt-cacher-ng, it was necessary to modify "PassThroughPattern". I wondered if I should have configured it on default package, but I leave it.

> Is there a smoke test to confirm that rpm's install all relevant config files, or to run the cache against some specific urls /mirrors to confirm that it's doing its job? I can see that such tests could be flakey as they may include external urls.

No, I haven't. I will make it soon.

Comment 10 Fedora Update System 2017-07-17 04:51:05 UTC
apt-cacher-ng-3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-07-17 09:19:56 UTC
apt-cacher-ng-3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-07-23 18:49:43 UTC
apt-cacher-ng-3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.