Bug 1467108 - Blank transition from an animated png wallpapers
Blank transition from an animated png wallpapers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: f26-backgrounds (Show other bugs)
26
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Luya Tshimbalanga
Fedora Extras Quality Assurance
RejectedFreezeException
: Reopened
Depends On: 1450260
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-02 19:02 EDT by Luya Tshimbalanga
Modified: 2017-07-11 16:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: f26-backgrounds-26.2.5-1.fc26 f26-backgrounds-26.2.6-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 16:55:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2017-07-02 19:02:55 EDT
Description of problem:
A bug from mutter led to a blank transition to animated wallpaper in PNG format.
Workaround is to use JPEG images instlead

Version-Release number of selected component (if applicable):
26.2.1

How reproducible:
Always

Steps to Reproduce:
1.Set animated PNG wallpaper
2.
3.

Actual results:
A blank in a transition from a PNG image to another

Expected results:
Smoother transition

Additional info:
As found by a reporter:

As noted by someone else on bodhi[0], this bug still exists in f26-backgrounds-26.2.2-1.

I have discovered that if all wallpapers are converted from PNG to JPEG format, the transitions work as expected. Indeed, the default GNOME animated background and previous Fedora animated backgrounds all used JPEG images, so this is likely to be an issue with GNOME's handling of transitions with PNG images.


[0]: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f9e2042dc
Comment 1 Luya Tshimbalanga 2017-07-02 19:07:26 EDT
Add depending bug for clarification.
Comment 2 Fedora Update System 2017-07-02 19:09:46 EDT
f26-backgrounds-26.2.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9ab2094727
Comment 3 Fedora Blocker Bugs Application 2017-07-02 19:10:33 EDT
Proposed as a Freeze Exception for 26-final by Fedora user luya using the blocker tracking app because:

 A bug from mutter caused a blank transition from an animated PNG default wallpapers as used on Fedora 26. This fix uses JPG images instead
Comment 4 Kevin Kofler 2017-07-03 04:54:53 EDT
Are you sure that this change is not breaking other desktops also using the wallpaper? E.g., I see that you had to change the file list for -xfce, does that not need a configuration change to match?
Comment 5 Matthew Miller 2017-07-03 10:55:36 EDT
-1 FE because of risk to other desktops.

Also, I'd like the default wallpaper to at least be included somewhere in PNG format; it seems to only be in the JPEG converted versions now.
Comment 6 Fedora Update System 2017-07-03 14:24:26 EDT
f26-backgrounds-26.2.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9ab2094727
Comment 7 Adam Williamson 2017-07-03 14:45:42 EDT
Discussed at 2017-07-03 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-07-03/f26-blocker-review.2017-07-03-16.06.html . Rejected as a freeze exception issue: the concerns about effects on other desktops seem valid, and the usefulness of fixing this in the final compose seems quite limited. We would be happier for this to go through the full normal update cycle and go out as a regular update, perhaps preferring to fix the bug in mutter rather than changing the backgrounds we ship...
Comment 8 Fedora Update System 2017-07-05 01:53:08 EDT
f26-backgrounds-26.2.5-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8081fffde3
Comment 9 Fedora Update System 2017-07-05 14:49:13 EDT
f26-backgrounds-26.2.5-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8081fffde3
Comment 10 Fedora Update System 2017-07-06 16:58:25 EDT
f26-backgrounds-26.2.6-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ac1481dbfe
Comment 11 Fedora Update System 2017-07-07 19:08:33 EDT
f26-backgrounds-26.2.5-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2017-07-08 22:52:59 EDT
f26-backgrounds-26.2.6-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ac1481dbfe
Comment 13 Fedora Update System 2017-07-11 16:55:39 EDT
f26-backgrounds-26.2.6-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.