Bug 1467136 - gst-transcoder update in updates-testing wont install
gst-transcoder update in updates-testing wont install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gst-entrans (Show other bugs)
26
ia64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Theodore Lee
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-02 22:13 EDT by Bill
Modified: 2017-07-12 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: gst-entrans-1.2.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 10:51:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill 2017-07-02 22:13:01 EDT
Description of problem:

gst-transcoder update in updates-testing wont install

Upgrading:
 gst-transcoder      x86_64      1.12.0-1.fc26       updates-testing       53 k

Transaction Summary
================================================================================
Upgrade  1 Package

Error: Transaction check error:
  file /usr/lib64/gstreamer-1.0/libgsttranscode.so from install of gst-transcoder-1.12.0-1.fc26.x86_64 conflicts with file from package gstreamer1-plugins-entrans-1.0.3-2.fc26.x86_64



Fc26 beta is otherwise fully updated.
Comment 1 Gwyn Ciesla 2017-07-03 10:05:49 EDT
Updating gst-entrans doesn't resolve this but I'm doing it anyway.  Since both packages provide this solib, it might be prudent to have gst-entrans exclude it and require gst-transcoder, if that works.  Reassinging to gst-entrans for evaluation.
Comment 2 Theodore Lee 2017-07-03 22:22:58 EDT
Unfortunately, unless I'm reading something wrong here, it looks like both these packages provide different GStreamer plugins with the same soname. The one from gst-entrans is a GStreamer implementation of various filters from the old transcode command, while I'm guessing gst-transcoder is a transcoding API for use in Pitivi.

gst-entrans started namespacing its gst elements in 1.2.0 to avoid conflicts, but I don't think this extends to plugins. If it seems like the right course of action, I can get in touch with GEntrans upstream and see about changing the plugin and lib name.
Comment 3 Gwyn Ciesla 2017-07-05 10:19:40 EDT
Please do.  They may have another solution, but this should really be resolved upstream as much as possible.  If I need to modify the gst-transcoder RPM I can certainly do that.
Comment 4 Theodore Lee 2017-07-06 01:38:19 EDT
Filed upstream for gst-entrans at: https://sourceforge.net/p/gentrans/bugs/6/
Comment 5 Fedora Update System 2017-07-07 04:23:23 EDT
gst-entrans-1.2.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-366dfb242c
Comment 6 Theodore Lee 2017-07-07 04:32:21 EDT
This has been fixed upstream in gst-entrans by namespacing the plugin sonames - gst-entrans-1.2.1-1.fc26 should hopefully resolve this conflict.

I wonder if it might still be worth notifying gst-transcoder upstream about this, as I doubt these will be the only two projects out there with the notion to name a GStreamer plugin "transcode". =)
Comment 7 Gwyn Ciesla 2017-07-07 09:13:09 EDT
Agreed.  Done.

https://github.com/pitivi/gst-transcoder/issues/5
Comment 8 Thibault Saunier 2017-07-07 09:55:01 EDT
For your information, gst-transcoder should be merged in -bad this cycle so having gst-entrans fixing it is probably a good idea as libgsttranscode will 'deserve' not to be extra namespaced.
Comment 9 Fedora Update System 2017-07-08 22:53:33 EDT
gst-entrans-1.2.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-366dfb242c
Comment 10 "FeRD" (Frank Dana) 2017-07-11 21:22:17 EDT
Hrm. This appears to now be breaking Fedora 26 release, where gst-entrans-1.0.3-2 and gst-transcode-1.12.0-1 are being disted together. I just hit the same conflict message that Bill reported, attempting to do a commandline upgrade from F25 via `dnf system-upgrade`.

I'm sure uninstalling one/both packages before upgrade will sort it out for me, but it'd be nice to get this pushed to stable if it does indeed solve the file-conflict problem.
Comment 11 Bill 2017-07-11 22:12:29 EDT
The "fix" is in updates-testing which I think isn't used for for system-upgrade. You probably have to wait until it gets promoted from testing to the normal updates repo. Otherwise you could remove the problem package under f25 then run the upgrade to f26. After the upgrade to f26 is complete, enable updates-testing and reinstall the removed packages. I least that is what I would try.
Comment 12 Theodore Lee 2017-07-11 22:20:39 EDT
I will go ahead and get this queued for stable ASAP, but at the moment as per Fedora updates policy, it needs at least four more days in testing or some positive testing feedback.
Comment 13 "FeRD" (Frank Dana) 2017-07-11 22:34:23 EDT
From comment 11 :
> Otherwise you could remove the problem package under f25 then run the upgrade to f26.

Exactly what I did, and so far... well, the upgrade is still ongoing, but the download, sanity-checks, and `dnf system-upgrade reboot` went off without a hitch so I'm sure it's fine.

I went scorched-earth and removed both conflicting packages, plus gst-entrans and pitivi, each of which depends on one of the two conflicting RPMs. That made the system-upgrade preflight happy, and with dnf's trigger-happy purging solved nothing had to be redownloaded to restart the process.

From comment 12 :
> I will go ahead and get this queued for stable ASAP, but at the moment as
> per Fedora updates policy, it needs at least four more days in testing or
> some positive testing feedback.

Thanks Ted, once my laptop is finally up and running with F26 I'll install the updates-testing build and file a report in bodhi.
Comment 14 "FeRD" (Frank Dana) 2017-07-12 00:25:26 EDT
I documented this to the F26 Common Bugs wiki page:

https://fedoraproject.org/wiki/Common_F26_bugs#Upgrade_may_fail_due_to_a_conflict_in_gstreamer_components

Looks like I don't have the necessary rights to set the CommonBugs keyword on this bug, though, or to add that URL to the Whiteboard. (https://fedoraproject.org/wiki/Common_bugs_instructions indicates that both should be done as part of documenting a Common Bugs entry.)
Comment 15 Theodore Lee 2017-07-12 02:39:06 EDT
Thank you, I've made those changes to this bug report.
Comment 16 Fedora Update System 2017-07-12 10:51:28 EDT
gst-entrans-1.2.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.