Bug 1467169 - [RFE] please provide libsolv Python bindings
[RFE] please provide libsolv Python bindings
Status: ON_QA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libsolv (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Igor Gnatenko
Desktop QE
: FutureFeature, Triaged
Depends On:
Blocks: 1465906 1466368
  Show dependency treegraph
 
Reported: 2017-07-03 02:08 EDT by Dan Callaghan
Modified: 2017-09-22 03:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: libsolv-0.6.26-2.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2017-07-03 02:08:55 EDT
For our rpmdeplint tool (static analysis for RPM dependencies [1]) we recently switched from using the deprecated hawkey library to using the libsolv Python bindings directly (bug 1422873).

RHEL7 currently ships libsolv 0.6.20 but it does not include any Python bindings for libsolv. Can you please add the Python bindings so that it's possible to use libsolv from Python tools.

[1] https://pagure.io/rpmdeplint
Comment 2 Igor Gnatenko 2017-09-22 02:11:32 EDT
commit a6e72b19f1ed9349097fdaf27d5d47c8decdcf39 (HEAD -> rhel-7.5, origin/rhel-7.5)
Author: Igor Gnatenko <ignatenko@redhat.com>
Date:   Fri Sep 22 07:55:01 2017 +0200

    Enable python bindings
    
    Resolves: RHBZ #1467169
    
    Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.