Bug 1467249 - Dolphin's Tooltip & Information Panel Not Displaying Video Metadata
Dolphin's Tooltip & Information Panel Not Displaying Video Metadata
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dolphin (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 04:57 EDT by Stephen Graham
Modified: 2017-07-04 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-04 18:32:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Graham 2017-07-03 04:57:56 EDT
Description of problem:

When hovering over a video file in Dolphin the tooltip is missing the extra metadata information about the video such as duration, bitrate, width, height etc.

Same goes for the Information Panel.

Version-Release number of selected component:

Dolphin Version 17.04.1

How reproducible:

Always.

Steps to Reproduce:

Hover over a video file.

Actual results:

Tooltip only shows Type and Size (in addition to Tags, Rating & Comment)

Expected results:

Actual result PLUS video metadata such as duration, bitrate, width, height, etc.
Comment 1 Stephen Graham 2017-07-04 05:04:47 EDT
After digging around I realize the problem is caused by a missing file - kfilemetadata_ffmpegextractor.so

This is because the kf5-kfilemetadata package has been built without the global ffmpeg variable set to 1.

I've downloaded the kf5-kfilemetadata source and re-built it with the ffmpeg global set to 1. After installing this updated version of kf5-kfilemetadata I can now see the video metadata in Dolphin.
Comment 2 Stephen Graham 2017-07-04 18:32:25 EDT
Since kfilemetadata_ffmpegextractor is dependent on ffmpeg.devel which is not in the official Fedora repositories I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.