Bug 146726 - vncserver on boot will not allow running of config / admin tools
vncserver on boot will not allow running of config / admin tools
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 20:24 EST by Carlos
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 08:44:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/init.d/vncserver (1.98 KB, text/plain)
2005-02-01 06:19 EST, Tim Waugh
no flags Details

  None (edit)
Description Carlos 2005-01-31 20:24:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Created user called Homer. Disabled iptables and prevented it from 
starting. Edited /etc/sysconfig/vncservers to create a session for 
Homer on :1. Set vncserver to start on Runlevel 5. Everything seems 
to work properly. Reboot server. Can connect to myserver:1 and can 
see Homers desktop. When trying to run any admin/configuration tool 
such as services they will not launch at all. I have tried killing as 
many process as possible but they just will not run. I can do 
anything else and even su in a terminal window, but cannot run any 
gui applet *that requires root password*. The only way will work is 
to kill the vnc session manually and then ssh in to recreate the vnc 
session. Now I just ssh in and start the session manually. I have 
tried creating an rc.vnc script and putting a link to it in rc5.d but 
it does the same thing.

Version-Release number of selected component (if applicable):
vnc-server-4.0.8

How reproducible:
Always

Steps to Reproduce:
1.Install FC3
2.Create user other than root
3.Edit /etc/sysconfig/vncservers to create session :1 for user
4.Temporarily disable or allow access to tcp 5901 in iptables
5.Set vncserver to start automatically on Runlevel 5
6.Reboot
7.Connect to vnc session :1 and try to run any config / admin utility


Actual Results:  Get prompted for root password and pam keys show up 
in tray, but application does not start.

Expected Results:  Get prompted for root password and have 
application start

Additional info:
Comment 1 Tim Waugh 2005-02-01 06:19:50 EST
Created attachment 110495 [details]
/etc/init.d/vncserver

Please try this replacement for /etc/init.d/vncserver.
Comment 2 Carlos 2005-02-02 08:44:39 EST
Downloaded attachment and replaced /etc/init.d/vncserver. vncserver now 
behaving as expected.  *note* this fix only works by 
using /etc/sysconfig/vncservers and setting vncserver service runlevels.  if 
other means are used to start a vnc session it still doesn't seem to work.  
otherwise it now works perfectly. - thank you

Note You need to log in before you can comment on or make changes to this bug.