Bug 146729 - multiple instances of poweroff?
multiple instances of poweroff?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 21:42 EST by bill parducci
Modified: 2013-07-02 19:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-06 11:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bill parducci 2005-01-31 21:42:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
i see the following on a relatively clean fc3 install that has been
yum'd recently...

multiple poweroffs:

$ whereis poweroff
poweroff: /usr/bin/poweroff /sbin/poweroff
/usr/share/man/man8/poweroff.8.gz

that don't match:

$ diff /usr/bin/poweroff /sbin/poweroff
Binary files /usr/bin/poweroff and /sbin/poweroff differ

because they are symlinks to different things:

$ ls -al /usr/bin/poweroff
/usr/bin/poweroff -> consolehelper

$ ls -al /sbin/poweroff
/sbin/poweroff -> halt

checking to make sure what these were pointing to i further found two
halts:

$ ls -al  /usr/bin/halt
/usr/bin/halt -> consolehelper

$ ls -al /sbin/halt
/sbin/halt

at the very least, this creates an interesting dependency on the
current PATH of the user. is this intentional?

b

Version-Release number of selected component (if applicable):
usermode-1.74-1

How reproducible:
Always

Steps to Reproduce:
1. whereis poweroff
2.
3.
    

Actual Results:  see above.

Expected Results:  a single instance?

Additional info:
Comment 1 Jindrich Novy 2005-04-06 04:50:15 EDT
Right, I can see this on my FC3 box. This really looks like a duplicated
functionality.

Bill, it looks like we need to remove all this stuff either from usermode or
SysVinit.

IMHO the best solution is to remove the commands from usermode as these commands
fit better to SysVinit.
Comment 4 Jindrich Novy 2005-04-06 11:31:02 EDT
This seems to be actually a feature as the usermode halt, poweroff, etc. in
/usr/bin/ serves a purpose that a non-root user can execute these commands after
successful authentication using consolehelper. So they're used as an interface
to the original SysVinit halt, etc. so there's no functionality duplication here.

Note You need to log in before you can comment on or make changes to this bug.