Bug 1467293 - dnf repoquery --duplicated --latest-limit -1 // argument --latest-limit: expected one argument
dnf repoquery --duplicated --latest-limit -1 // argument --latest-limit: expe...
Status: CLOSED DUPLICATE of bug 1446641
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 06:25 EDT by srakitnican
Modified: 2017-08-04 07:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 07:38:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description srakitnican 2017-07-03 06:25:12 EDT
Description of problem: "-1" in "--latest-limit -1" seems to be invalid argument with dnf 2.0, something that used to work with dnf 1.x for removing duplicate packages.


Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-2.4.1-1.fc26.noarch
dnf-2.5.1-1.fc26.noarch


How reproducible: Always


Steps to Reproduce:
1. $ sudo dnf repoquery --duplicated --latest-limit -1

Actual results: Command line error: argument --latest-limit: expected one argument


Expected results:


Additional info: This system failed to upgrade most likely because libdb issue RHBZ#1465292 .
Comment 1 srakitnican 2017-07-03 06:29:14 EDT

*** This bug has been marked as a duplicate of bug 1446641 ***
Comment 2 srakitnican 2017-07-03 06:30:59 EDT
Thank you. Workarounds mentioned in other bug reports works.
Comment 3 Jaroslav Mracek 2017-08-04 07:38:32 EDT
I am sorry but the problem here was solved by providing a workaround including examples in documentation. The other solution cannot be provided with Python argparser.

*** This bug has been marked as a duplicate of bug 1446641 ***

Note You need to log in before you can comment on or make changes to this bug.