Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1467295 - Cloned MAC address does not become active when set via control-center
Cloned MAC address does not become active when set via control-center
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.4
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 06:32 EDT by Pavlin Georgiev
Modified: 2018-05-17 10:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: control-center-3.26.2-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 08:57:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System journal when setting cloned MAC address (129.54 KB, text/x-vhdl)
2017-07-03 06:32 EDT, Pavlin Georgiev
no flags Details
Connection status, journal, and log from debug mode (292.77 KB, application/x-gzip)
2018-02-13 11:22 EST, Pavlin Georgiev
no flags Details
Connection status, journal, and log from debug mode - additional (12.59 KB, application/x-gzip)
2018-02-13 12:03 EST, Pavlin Georgiev
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 793072 None None None 2018-01-31 11:08 EST
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 08:59 EDT

  None (edit)
Description Pavlin Georgiev 2017-07-03 06:32:33 EDT
Created attachment 1293807 [details]
System journal when setting cloned MAC address

Summary
Cloned MAC address does not become active when set via control-center

Description of the problem:
When I open control-center to assign a cloned MAC address to a network adapter, the cloned MAC address is ignored.

Hostname: qe-dell-ovs5-vm-59
Kernel: kernel-3.10.0-691.el7.x86_64

Version-Release number of selected component:
control-center-3.22.2-5.el7.x86_64
NetworkManager-1.8.0-9.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
Open a terminal.
Choose the name of the connection you will monitor:
	nmcli con show
I choose "testeth1".
Monitor the properties of that connection:
	watch "nmcli -f 802-3-ethernet connection show testeth1"
-----------------------
Start control-center.
Open "Network".
Chose the same network connection.
Deactivate the connection.
Open its profile by pressing [*].
Open section "Identity".
In the field "Cloned Address" enter the value "1a:2b:3c:4d:5e:6f".
Apply the changes.
Activate the connection.
The bug appears.


Actual results:
The cloned MAC address is ignored.
Have a look at the monitoring terminal.
Check the field "802-3-ethernet.cloned-mac-address".
It's empty, but should contain "1A:2B:3C:4D:5E:6F".


Expected results:
The cloned MAC address becomes effective.

Additional info:
If you test the same thing under RHEL 7.3, you will see that it works.
Comment 4 Bastien Nocera 2018-01-31 10:57:42 EST
Reading the bug, control-center-3.14 (RHEL 7.3) didn't have that bug, but control-center 3.22 (RHEL 7.5) did.

This seems to be caused by a bug in this commit:
commit 9183d3494788486600856df5115f11486ecb20a8
Author: Bastien Nocera <hadess@hadess.net>
Date:   Fri Apr 29 16:05:54 2016 +0200

    network: Port to libnm 1.2
    
    We also remove support for WiMAX (now unsupported by NetworkManager),
    and InfiniBand (Enterprise feature), and the use of
    the deprecated NM_SETTING_WIRELESS_SEC property.
    
    With help from network-manager-applet patches by Jiří Klimeš and
    Dan Winship.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=765910
Comment 7 Pavlin Georgiev 2018-02-13 11:21:14 EST
Component version:
control-center-3.22.2-5.el7

TEST SETUP 1
On a VM install RHEL-7.4-20170711.0.


TEST PROCEDURE 1
1. Start gnome-control-center.
2. Select a network interface and create a new profile for it.
3. Specify name "test-connection".
4. Set cloned MAC address to "1a:2b:3c:4d:5e:6f".
5. Activate that connection
6. Open a terminal and issue command:
    nmcli -f 802-3-ethernet con show test-connection
The bug appears.

Actual results:
802-3-ethernet.cloned-mac-address:      --

Expected results:
802-3-ethernet.cloned-mac-address:      1A:2B:3C:4D:5E:6F


TEST SETUP 2
On a VM install RHEL-7.5-20180211.0.
Download build control-center-3.26.2-4.el7 from Brew server. Install provided RPMs.


TEST PROCEDURE 2
1. Start gnome-control-center.
2. Select a network interface and create a new profile for it.
3. Specify name "test-connection".
4. Set cloned MAC address to "1a:2b:3c:4d:5e:6f".
5. Activate that connection
6. Open a terminal and issue command:
    nmcli -f 802-3-ethernet con show test-connection
Another bug appears.

Actual results:
802-3-ethernet.cloned-mac-address:      52:54:02:2C:E1:53
This is the MAC address of the interface to which network profile "test-connection" is assigned to.

Expected results:
802-3-ethernet.cloned-mac-address:      1A:2B:3C:4D:5E:6F


RESULTS
Bug is not fixed.
Comment 8 Pavlin Georgiev 2018-02-13 11:22 EST
Created attachment 1395475 [details]
Connection status, journal, and log from debug mode
Comment 9 Pavlin Georgiev 2018-02-13 12:03 EST
Created attachment 1395555 [details]
Connection status, journal, and log from debug mode - additional

I ran the same test on another host which has 10 Ethernet interfaces.
For example: qe-dell-ovs5-vm-4.dqe.lab.eng.bos.redhat.com

After assigning a cloned MAC on interface ens7, I have the same result.
MAC address of ens7 appears as clonned, but sould be "1A:2B:3C:4D:5E:6F".
Comment 11 Vitezslav Humpa 2018-02-15 10:11:03 EST
Testing the c#10 scratchbuild. Still appears buggy. If I go according to Pavlin and only set the Cloned mac address field, nothing happens. If I select the original mac address in the MAC Address combo, put new address in the Cloned field, apply, both fields end up the original mac again. Now, I set BOTH the fields to cloned mac address, the setting is in fact applied to both fields:

802-3-ethernet.mac-address:             1A:2B:3C:4D:5E:6F
802-3-ethernet.cloned-mac-address:      1A:2B:3C:4D:5E:6F

and the entire Wired profile disappears from the Network control center panel (likely a broken profile) (accessible via nmcli/tui still).
Comment 12 Bastien Nocera 2018-02-16 08:28:32 EST
Finally fixed (and tested) upstream, and backported to control-center-3.26.2-6.el7
Comment 13 Pavlin Georgiev 2018-02-16 09:36:51 EST
TEST SETUP
Install RHEL-7.5-20180215.1
on host qe-dell-ovs5-vm-56.dqe.lab.eng.bos.redhat.com.
Download from Brew server the latest build of control-center.
Install provided RPM packages.


TEST PROCEDURE
1. Start control-center.
2. Open section "Network".
3. Edit connection profile "ens7".
4. Add cloned MAC address "1A:2B:3C:4D:5E:6F".
5. Save the profile.
6. Issue command:
    nmcli -f 802-3-ethernet con show ens7
7. The expected result is there:
802-3-ethernet.cloned-mac-address:      1A:2B:3C:4D:5E:6F


RESULTS
Upgrading the component: control-center
    from: 3.22.2-5.el7
      to: 3.26.2-6.el7
has fixed the bug.
Comment 16 errata-xmlrpc 2018-04-10 08:57:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.