Bug 1467307 - catalog controller manager pod is not running with openshift v3.6.131
catalog controller manager pod is not running with openshift v3.6.131
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jeff Peeler
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 07:03 EDT by Johnny Liu
Modified: 2017-08-16 15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog controller manager log (34.67 KB, text/plain)
2017-07-03 07:03 EDT, Johnny Liu
no flags Details

  None (edit)
Description Johnny Liu 2017-07-03 07:03:56 EDT
Created attachment 1293827 [details]
catalog controller manager log

Description of problem:
After workaround BZ#1466727, continue testing. See the following details.

Version-Release number of selected component (if applicable):
openshift v3.6.131

How reproducible:
Always

Steps to Reproduce:
1. enable catalog service deployment in inventory host file
2. trigger installation
3.

Actual results:
installation failed at the following task:
<--snip-->
TASK [ansible_service_broker : Create the Broker resource in the catalog] ******
Monday 03 July 2017  09:59:16 +0000 (0:00:01.835)       0:34:45.273 *********** 

fatal: [openshift-120.lab.sjc.redhat.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

{u'returncode': 1, u'cmd': u'/usr/bin/oc create -f /tmp/brokerout-yIU50J -n default', u'results': {}, u'stderr': u'error: unable to recognize "/tmp/brokerout-yIU50J": no matches for servicecatalog.k8s.io/, Kind=Broker\n', u'stdout': u''}
<--snip-->


After the above failure, go to kube-service-catalog project, found controler manager pod is not running.

# oc get po
NAME                       READY     STATUS             RESTARTS   AGE
apiserver-bdsr2            1/1       Running            0          3m
controller-manager-0nvqk   0/1       CrashLoopBackOff   3          3m

Pls refer to attachment for pod log.



Expected results:
should be successful.

Additional info:
Try a lower version of openshift - v3.6.126.8, no such issue.
Comment 5 Jeff Peeler 2017-07-03 12:55:17 EDT
kubectl api-versions is not returning servicecatalog.k8s.io/v1alpha1 as expected, but I don't know why discovery is not finding that group.

The problem doesn't appear to be with the certificates or with the discovery cache being stale.
Comment 9 David Eads 2017-07-05 08:50:38 EDT
We tried again in https://github.com/openshift/origin/pull/15022.  I'm surprised it took this long to fail.  These tests don't block merge?
Comment 10 Derek Carr 2017-07-05 10:14:13 EDT
Jeff to verify with latest commit, on success move to MODIFIED.
Comment 11 Jeff Peeler 2017-07-05 10:54:52 EDT
origin/master is working as expected
Comment 13 Johnny Liu 2017-07-06 05:14:13 EDT
Verified this bug with openshift3/ose-service-catalog:latest (eb2a9b361302) and atomic-openshift-3.6.135-1.git.0.56fd7dc.el7.x86_64, installation is finished successfully, and controller-manager is running well.


# oc get po
NAME                       READY     STATUS    RESTARTS   AGE
apiserver-462z1            1/1       Running   0          5h
controller-manager-hdpgj   1/1       Running   1          5h
Comment 15 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.