Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1467362

Summary: Running HE CLI commands shows "Exception AttributeError"
Product: [oVirt] ovirt-hosted-engine-setup Reporter: Artyom <alukiano>
Component: GeneralAssignee: Simone Tiraboschi <stirabos>
Status: CLOSED CURRENTRELEASE QA Contact: Artyom <alukiano>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 2.2.0CC: bugs, dfediuck, stirabos, ylavi
Target Milestone: ovirt-4.2.0Keywords: Triaged
Target Release: 2.2.1Flags: rule-engine: ovirt-4.2+
rule-engine: exception+
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-20 10:50:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Artyom 2017-07-03 14:06:19 UTC
Description of problem:
Running HE CLI commands shows
# hosted-engine --vm-start
Virtual machine does not exist: {'vmId': '941b0878-461c-429c-aefc-0287d7eca971'}
Exception AttributeError: "'NoneType' object has no attribute 'dispatcher'" in <bound method _Server.__del__ of <vdsm.jsonrpcvdscli._Server object at 0x16840d0>> ignored
Exception AttributeError: "'NoneType' object has no attribute 'dispatcher'" in <bound method _Server.__del__ of <vdsm.jsonrpcvdscli._Server object at 0xec4e50>> ignored

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.2.0-0.0.master.20170616124434.20170616124430.git18dac95.el7.centos.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine
2. Run some CLI command that uses of VDSM API
3.

Actual results:
Command succeeded, but I can see some error message(see above)

Expected results:
Command succeed with some nice looking print out

Additional info:
VDSM log contains some Tracebacks

Comment 1 Jenny Tokar 2017-07-04 13:12:32 UTC
Looks like by the time we are closing the json rpc client connection some of the fields are already empty. 
More specifically, the error is thrown from the close method in the betterAsyncore.py class. The 'asyncore' library seems to be None and we are getting the reported error.

Comment 2 Simone Tiraboschi 2017-07-04 21:54:41 UTC
https://gerrit.ovirt.org/78166/ wasn't related

Comment 3 Red Hat Bugzilla Rules Engine 2017-07-04 21:54:48 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Artyom 2017-09-17 07:58:54 UTC
Still, can see it on 
ovirt-hosted-engine-ha-2.2.0-0.0.master.20170914130805.20170914130802.git82df275.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20170913082146.git120d800.el7.centos.noarch

# hosted-engine --vm-start
Virtual machine does not exist: {'vmId': 'c2ee6bf8-a02a-4b1b-8435-a1e97f0ebb6f'}
Exception AttributeError: AttributeError("'NoneType' object has no attribute 'c_uint64'",) in <bound method _Server.__del__ of <vdsm.jsonrpcvdscli._Server object at 0x293d110>> ignored

Comment 5 Red Hat Bugzilla Rules Engine 2017-09-17 07:58:57 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 6 Simone Tiraboschi 2017-11-27 13:58:10 UTC
Fixed consuming the new json rpc client

Comment 7 Artyom 2017-12-13 07:19:28 UTC
Verified on ovirt-hosted-engine-setup-2.2.1-1.el7ev.noarch

Comment 8 Sandro Bonazzola 2017-12-20 10:50:10 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.