Bug 1467397 - os-image modifier in python-tripleoclient causes conflict with OS_IMAGE from glance
os-image modifier in python-tripleoclient causes conflict with OS_IMAGE from ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
urgent Severity urgent
: Upstream M1
: 13.0 (Queens)
Assigned To: Julie Pichon
Gurenko Alex
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 12:00 EDT by Yolanda Robla
Modified: 2018-01-22 09:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-22 09:42:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1693344 None None None 2017-07-03 12:00 EDT
OpenStack gerrit 480036 None None None 2018-01-22 09:42 EST

  None (edit)
Description Yolanda Robla 2017-07-03 12:00:14 EDT
When using the --os-image command from python-tripleoclient, that gets translated into the OS_IMAGE env var:

757 parser.add_argument(
758 "--os-image",
759 default=os.environ.get('OS_IMAGE', 'overcloud-full.qcow2'),
760 help=_("OpenStack disk image filename"),

But when we try to use it, we are getting this error:

image version overcloud-full.qcow2 is not in supported versions 1, 2
Invalid image client version 'overcloud-full.qcow2'. must be one of: 1, 2

That is actually because OS_IMAGE env var ends somehow being part of os_client_config in the openstackclient:

{'auth_type': 'password', 'beta_command': False, 'tripleoclient_api_version': '1', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'metrics_api_version': '1', 'data_proce
ssing_api_version': '1.1', 'inspector_api_version': '1', 'auth_url': 'http://192.168.24.1:5000/v2.0', u'network_api_version': u'2', u'message': u'', u'image_format': u'qcow2', 'networks': [], u'imag
e_api_version': u'overcloud-full.qcow2' }

This bug has been tested with stable/newton
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-03 12:00:58 EDT
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.
Comment 4 Julie Pichon 2018-01-22 09:42:18 EST
Looking at the upstream bug, this was fixed in Pike / OSP12.

Note You need to log in before you can comment on or make changes to this bug.