Bug 1467407 - SELinux is preventing ibus-daemon from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.
SELinux is preventing ibus-daemon from 'read' accesses on the lnk_file /var/l...
Status: CLOSED DUPLICATE of bug 1467036
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:428a9a08b5adff49151e60cd3df...
:
: 1470412 1473428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 13:01 EDT by gesserat
Modified: 2017-07-20 15:28 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-08 14:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gesserat 2017-07-03 13:01:55 EDT
Description of problem:
SELinux is preventing ibus-daemon from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ibus-daemon should be allowed read access on the machine-id lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ibus-daemon' --raw | audit2allow -M my-ibusdaemon
# semodule -X 300 -i my-ibusdaemon.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                /var/lib/dbus/machine-id [ lnk_file ]
Source                        ibus-daemon
Source Path                   ibus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-259.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.7-300.fc26.x86_64 #1 SMP Mon
                              Jun 26 14:54:05 UTC 2017 x86_64 x86_64
Alert Count                   6
First Seen                    2017-07-03 14:35:40 MSK
Last Seen                     2017-07-03 17:21:03 MSK
Local ID                      f996e4e1-725b-498f-807a-ea06775c88e3

Raw Audit Messages
type=AVC msg=audit(1499091663.502:285): avc:  denied  { read } for  pid=1666 comm="gsd-power" name="machine-id" dev="dm-1" ino=800764 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: ibus-daemon,xdm_t,system_dbusd_var_lib_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.7-300.fc26.x86_64
type:           libreport
Comment 1 Archie 2017-07-05 10:44:26 EDT
Description of problem:
Not aware of the exact steps

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64
type:           libreport
Comment 2 Per Nyfelt 2017-07-05 15:22:19 EDT
Description of problem:
The security alert popped up when I was browsing the web. 

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.i686
type:           libreport
Comment 3 Mikhail 2017-07-06 22:34:15 EDT
Description of problem:
Occured during last dnf update

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64+debug
type:           libreport
Comment 4 Karl Hastings 2017-07-08 14:52:45 EDT

*** This bug has been marked as a duplicate of bug 1467036 ***
Comment 5 Chris Jenkins 2017-07-12 20:09:18 EDT
*** Bug 1470412 has been marked as a duplicate of this bug. ***
Comment 6 bugzilla 2017-07-20 15:28:56 EDT
*** Bug 1473428 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.