Bug 146741 - Problems and comments about the perl-Cache-Cache specfile
Problems and comments about the perl-Cache-Cache specfile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Cache-Cache (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 23:10 EST by Jose Pedro Oliveira
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 08:49:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2005-01-31 23:10:50 EST
Matthias Saou,

A couple of notes about the perl-Cache-Cache specfile:

1) there is at least a BuildRequirement missing (Digest::SHA1)
2) the first comment line mentions perl-Convert-UUlib
3) the spec should use the macro %{perl_vendorlib}
4) the spec should use the requirement 
5) the epoch for redhat perl 5.8.0 should be 2 (not 0)

For a specfile compliant with fedora.us module packaging see:
https://bugzilla.fedora.us/show_bug.cgi?id=1079  (comment 7)

The perl specfile template is available in the fedora.extras
fedora-rpmdevtools package.

Do you want me to supply a specfile patch?

Regards,
jpo
Comment 1 Matthias Saou 2005-02-01 04:45:40 EST
I've looked at your latest .src.rpm from the fedora.us bug and merged
in everything relevant I could find, which should fix the 5 points
above too. Please look at the current CVS spec and let me know if
anything more needs to be changed.
Comment 2 Matthias Saou 2005-02-02 08:49:13 EST
BTW, if you'd like to become owner of the perl-Cache-Cache component,
just let me know, as that would be fine by me. I'm the current one
because it's a package that wasn't available from fedora.us when the
move to Extras was done, and as I had it on freshrpms.net, mine got
imported.
Comment 3 Jose Pedro Oliveira 2005-02-02 15:16:02 EST
Matthias,

Feel free to assign me the maintainership of perl-Cache-Cache.  As I'm
already maintaining it for fedora.us, it won't cause much trouble.

Would you mind if in the near future I import the fedora.us specfile?
(I already maintain several perl specfiles using the same layout)

Note: Right now I still don't have write access to the Extras CVS, but
 I'm expecting to have it in the near future. 

Comment 4 Jose Pedro Oliveira 2005-02-15 16:40:22 EST
Matthias,

I finally have Read/Write access to the Extras CVS.

Do you still want me to take maintainership of this package?
Comment 5 Matthias Saou 2005-02-16 04:36:50 EST
Sure, go ahead. I also don't mind if you overwrite the current spec
with one you already had, as long as there are no regressions. Also,
make sure to request a bugzilla component owner change too.

Note You need to log in before you can comment on or make changes to this bug.