Bug 146743 - Printer package group is installed despite being unchecked during a custom installation.
Printer package group is installed despite being unchecked during a custom in...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 23:49 EST by Justin Szeto
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 23:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Szeto 2005-01-31 23:49:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
During a custom installation (I have not done a workstation, server,
etc) you are given the choice to deselect the printer package group,
which is by default checked. The printer package group is, however,
always installed regardless of the state of the checkbox.

Version-Release number of selected component (if applicable):
comps-3-0.20041103

How reproducible:
Always

Steps to Reproduce:
1. During custom installation of fc3, deselect the printer package
group under Systems.
2. Leave all other selections at default.
2. Continue with installation.
    

Actual Results:  The printer package group is installed anyway.

Expected Results:  Any of the following 3 is better than current.
1. Hide the printer package group.
2. Show it, but for informational purposes only. ie Remove the ability
to uncheck it.
3. Not install it when the checkbox is unchecked! (The best solution).

Additional info:

This is not an essential fix, but since I have no printer hardware and
I am a minimalist, it would be nice if the installer behaved as expected.
I have not gone through the comps file, but I suspect it may have to
do with either base-x or gnome requiring printing.???
Comment 1 Elliot Lee 2005-03-21 23:33:29 EST
Hmm, someone else reported similar things. Gnome does require the printing stuff
to be around in order for the gnome-print libraries to work, so that is probably
the explanation.
Comment 2 Justin Szeto 2005-03-22 00:11:48 EST
Hi Elliot!
I would argue that this is a bug. Maybe I was not very clear in my original
report. Whatever the reason for printing packages being installed is really
irrelevant. The point is that there is a check box next to the printing packages
during anaconda package selection, giving the illusion that the printing package
group is installable/not installable depending on the state of the check box.
However, since it is ALWAYS installed, I would argue that a check box is then
really pointless/misleading. Perhaps making this package group mandatory, or
some other solution, is better than present.
This bug is not shown when running up2date (? sorry if the package name is not
correct, I have not run fc3 for a few months now) as up2date shows the printer
package group as it shold be, ie not selectable/unselectable (no check box).
This is, however, not the case during anaconda installation.

Note You need to log in before you can comment on or make changes to this bug.