Bug 1467431 - GDBM_UNKNOWN_UPDATE definition problem
GDBM_UNKNOWN_UPDATE definition problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdbm (Show other bugs)
27
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Petr Kubat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 16:46 EDT by Jerry James
Modified: 2018-01-09 21:05 EST (History)
3 users (show)

See Also:
Fixed In Version: gdbm-1.14-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-09 21:05:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2017-07-03 16:46:12 EDT
Description of problem:
I hit a build failure with the latest version of clisp because of this definition in /usr/include/gdbm.h:

# define GDBM_UNKNOWN_UPDATE GDBM_ERR_UNKNOWN_ERROR

There is no such macro as GDBM_ERR_UNKNOWN_ERR.  There is a GDBM_UNKNOWN_ERROR on the other hand.

Version-Release number of selected component (if applicable):
gdbm-1.13-1.fc27

How reproducible:
Always

Steps to Reproduce:
1. Build clisp, or any program that refers to GDBM_UNKNOWN_UPDATE

Actual results:
Compilation failure due to an undefined macro.

Expected results:
Successful build.

Additional info:
Comment 1 Jan Kurik 2017-08-15 03:17:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 2 Petr Kubat 2018-01-03 01:40:06 EST
This has been fixed in the latest upstream release:

 /* This one was never used and will be removed in the future */
-# define GDBM_UNKNOWN_UPDATE GDBM_ERR_UNKNOWN_ERROR
+# define GDBM_UNKNOWN_UPDATE GDBM_UNKNOWN_ERROR
Comment 3 Petr Kubat 2018-01-03 02:07:26 EST
Created A PR against rawhide:
https://src.fedoraproject.org/rpms/gdbm/pull-request/1
Comment 4 Fedora Update System 2018-01-03 02:26:26 EST
gdbm-1.14-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-639290a9b9
Comment 5 Fedora Update System 2018-01-03 17:30:10 EST
gdbm-1.14-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-639290a9b9
Comment 6 Fedora Update System 2018-01-09 21:05:01 EST
gdbm-1.14-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.