Bug 146747 - System freezes
System freezes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 01:59 EST by Zenon Panoussis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: Fedora Core 4, with all updates applied
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2005-02-01 01:59:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Filed against distribution because I can't idenify the offending
component. 

The system keeps freezing hard and has to be hard-reset. This has only
been happening in the past two weeks, so it must be related to recent
updates. Empirical statistics point a finger at something to do with
video. The freezes always occur when attempting to view certain
things, never otherwise. Example: opening a certain html file with vi
is OK until the moment I scroll down to an <em> section. The very
moment I can see the beginning of the black <em> text on the screen,
the system freezes and I have to press the reset button. Every time.
But then again, it could have to do with the file itself and not with
its display. Another freeze comes often - but not always - with
opening a default icecast status page in mozilla, although opening the
same page in konqueror is just fine. No traces whatsoever in the logs.

The machine is an ASUS A7N8X-X with ATI Rage 128 Pro Ultra VGA running
2.6.10-1.741_FC3 or 2.6.9-1.724_FC3 kernel (no difference), KDE and
nothing particularly suspicious. Three partitions are encrypted with
dm-crypt, but two of them have been so for many months without
freezes. And yes, the heat sink is new and clean and the whole system,
motherboard, RAM and CPU, is brand new (bug #137804, comment #8). 

This is the typical elusive bug that won't let itself be easily
pinpointed, so I'm willing to give root to redhat staff that's willing
to take a go at it. 

How reproducible:
Sometimes
Comment 1 Zenon Panoussis 2005-02-07 00:12:24 EST
In the week that passed since I reported this, I have had one or two
non-vi-related freezes and more than a dozen directly triggered by vi.
With certain files it happens every single time, no exceptions. As I
found out, the vi help is one of them. I open vi, type ':help', start
scrolling down one line at a time. At the fourth line the machine
freezes. 

Normally I use KDE and vi in gnome-terminal. I tried in Gnome and it
froze too. I tried turning off syntax highlighting to no avail. I
tried in runlevel 3 and whoops, problem gone. I can open the vi help
and all the files that cause the freezes without any problems. 

BTW, all this happens with me logged in as an unprivileged user, not
as root.
Comment 2 Zenon Panoussis 2005-02-07 00:26:06 EST
One thing I hadn't checked is whether the machine could be accessed
from the network when the keyboard and mouse are frozen. Now I did and
it cannot. It doesn't even answer to ping, so it is really completely
frozen. 


Comment 3 Zenon Panoussis 2005-02-16 16:36:43 EST
Since I updated the machine yesterday with, among others, 
kdegraphics-3.3.1-2.3, things got worse. Much worse. I can hardly 
open mozilla mail without freezing, I had to press the reset button 
five times in the last half hour and move to kmail. This is more 
exhasperating than Windows 95 ever was. Kernel 766, 760 or 741 makes 
no difference; the system is absolutely useless. 
 
 
Comment 4 Zenon Panoussis 2005-02-16 20:36:27 EST
I compiled a vanilla 2.6.10 kernel using
/lib/modules/2.6.10-1.766_FC3/build/.config, with the only difference
that I added CONFIG_MK7=y. Rebooted, opened mozila mail and froze
before I could even enter a password. At least we know now that it's
not the redhat kernel patches that cause this. 

Subsequently I boouted the 766 fedora kernel, downgraded kdelibs to
3.3.1-2.4.FC3 and kdegraphics to 3.3.1-2.3 and restarted X. I was now
able to start mozilla mail and use it for more than ten minutes
without freezing. That's significant progress compared with an hour
ago, and it suggests a possible narrowing down. The timing described
in comment #1 coincides with the release of kdelibs-3.3.1-2.6.FC3. 

My gut feeling is that something userland triggers the freezes, and
the kernel then allows them to happen. That would certainly be a
kernel bug, but the userland problem is also a bug. Finding the
userland bug could help a lot in narrowing down the kernel bug. 

From here I'll go to downgrading kdelibs to 3.3.1-2.4 and see if it
makes any difference. All bright ideas what else to try are welcome. 

Comment 5 Dave Jones 2005-07-15 15:31:45 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Zenon Panoussis 2005-08-06 12:04:12 EDT
I won't be able to test this until next month. It's not lack of interest, so
please don't close the bug in the meanwhile. 
Comment 7 Zenon Panoussis 2005-09-23 11:47:30 EDT
I am finally back at that machine and tested it. With all FC3 updates up to
September 21, including the latest kernel, the system kept freezing as before.
It also kept freezing after I upgraded it to CentOS 4.1. Replacing the ATI Rage
128 video card with an ATI Radeon 7000 finally solved the problem. There doesn't
seem to be anything wrong with the Rage card hardware-wise, so the suspect is
the driver and whatever change was made to it around January this year. 
Comment 8 Mike A. Harris 2005-09-23 16:20:14 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.