Bug 146751 - Can't set different resolution on internal and external screen
Can't set different resolution on internal and external screen
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 05:08 EST by David Juran
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 15:28:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config (3.77 KB, text/plain)
2005-02-01 05:11 EST, David Juran
no flags Details

  None (edit)
Description David Juran 2005-02-01 05:08:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
I have a laptop Dell D600 which has a 1400x1050 LCD display. Now this
display _needs_ to have the reslution set to 1400x1050, if I try to
alter it with CTRL-ALT-+ or xrandr the displat goes black. Now this
isn't a major problem until I connect the laptop to a projector. Since
the projector can't handle resolutions higher then 1280x1024
(otherwise it goes black and complains about beeing out of sync) I end
up with having to use _either_ the built in LCD panel or the projector.
To remedy this I tried to set up different resolutions on the external
and internal port, but with little success. My Xfree86Conf is attached.
The graphics adapter in the laptop is a 

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf
[FireGL 9000] (rev 02)

Version-Release number of selected component (if applicable):
XFree86-4.3.0-78.EL

How reproducible:
Always

Steps to Reproduce:
1. Attach a projector that can't handle 1400x1050 resolution.
2. Note how you can't see the image on both the projector and LCD
3.
    

Additional info:
Comment 1 David Juran 2005-02-01 05:11:14 EST
Created attachment 110493 [details]
XF86Config
Comment 8 Mike A. Harris 2005-03-07 15:24:21 EST
I've reviewed this bug report and done some preliminary investigation
which seems to indicate that this problem appears to be a
configuration issue rather than a bug in the X server or video
driver.

In order to configure the server to do what you want, you will need
to edit the X server config file by hand and change some options,
which are describe on the "radeon" driver manpage.  You may need
to experiment with different options until you find a setup that
meets your specific requirements.

If you require assistance configuring the server, please contact
Red Hat Global Support Services directly at 1-888-RED-HAT1 for
technical support, and mention this bug report to the
support representative.




Comment 9 Mike A. Harris 2005-03-07 15:28:20 EST
Setting status to "NOTABUG" as per above assessment.
Comment 10 David Juran 2005-04-01 07:54:37 EST
In deed it was an configuration issue.
Adding the line
Option "CloneMode" "1280x1024"
to the "device" section of /etc/X11/XF86Config solved the problem

Note You need to log in before you can comment on or make changes to this bug.