Bug 1467515 - SELinux is preventing gsd-power from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.
SELinux is preventing gsd-power from 'read' accesses on the lnk_file /var/lib...
Status: CLOSED DUPLICATE of bug 1467036
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:7cbd1a78bc1d6fb31a6969c14f8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 02:12 EDT by Vít Ondruch
Modified: 2017-07-12 08:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 08:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2017-07-04 02:12:04 EDT
Description of problem:
SELinux is preventing gsd-power from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gsd-power should be allowed read access on the machine-id lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gsd-power' --raw | audit2allow -M my-gsdpower
# semodule -X 300 -i my-gsdpower.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                /var/lib/dbus/machine-id [ lnk_file ]
Source                        gsd-power
Source Path                   gsd-power
Port                          <Neznámé>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-261.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.12.0-0.rc7.git2.1.fc27.x86_64 #1
                              SMP Thu Jun 29 19:31:13 UTC 2017 x86_64 x86_64
Alert Count                   6
First Seen                    2017-07-04 08:00:40 CEST
Last Seen                     2017-07-04 08:09:33 CEST
Local ID                      f3f4d56d-fa6d-4677-a7fd-a722afea6308

Raw Audit Messages
type=AVC msg=audit(1499148573.126:252): avc:  denied  { read } for  pid=1168 comm="gnome-shell" name="machine-id" dev="dm-0" ino=1966349 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: gsd-power,xdm_t,system_dbusd_var_lib_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-261.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.12.0-0.rc7.git2.1.fc27.x86_64
type:           libreport
Comment 1 Daniel Walsh 2017-07-12 08:34:12 EDT

*** This bug has been marked as a duplicate of bug 1467036 ***

Note You need to log in before you can comment on or make changes to this bug.