Bug 1467538 - NoMethodError: undefined method `id' for "on":String
NoMethodError: undefined method `id' for "on":String
Status: CLOSED DUPLICATE of bug 1461939
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Nandini Chandra
api
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 03:32 EDT by Nandini Chandra
Modified: 2017-07-05 13:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-05 13:18:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2017-07-04 03:32:05 EDT
Description of problem:
------------------------
I found this error logged in the evm.log file.

[----] E, [2017-06-30T03:38:45.012715 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) API Error

[----] E, [2017-06-30T03:38:45.012909 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) NoMethodError: undefined method `id' for "on":String

[----] E, [2017-06-30T03:38:45.013121 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) API Error

[----] E, [2017-06-30T03:38:45.013289 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error)
[----] E, [2017-06-30T03:38:45.013401 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error)
[----] E, [2017-06-30T03:38:45.013495 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac/filterer.rb:203:in `collect'
[----] E, [2017-06-30T03:38:45.013613 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac/filterer.rb:203:in `search'
[----] E, [2017-06-30T03:38:45.013708 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac/filterer.rb:114:in `search'
[----] E, [2017-06-30T03:38:45.013818 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac.rb:3:in `search'
[----] E, [2017-06-30T03:38:45.013911 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac/filterer.rb:283:in `filtered'
[----] E, [2017-06-30T03:38:45.014005 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac/filterer.rb:118:in `filtered'
[----] E, [2017-06-30T03:38:45.014136 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/lib/rbac.rb:11:in `filtered'
[----] E, [2017-06-30T03:38:45.014245 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:172:in `virtual_attribute_search'
[----] E, [2017-06-30T03:38:45.014342 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:221:in `fetch_direct_virtual_attribute'
[----] E, [2017-06-30T03:38:45.014457 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:209:in `block in expand_virtual_attributes'
[----] E, [2017-06-30T03:38:45.014572 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:206:in `each'
[----] E, [2017-06-30T03:38:45.014667 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:206:in `expand_virtual_attributes'
[----] E, [2017-06-30T03:38:45.014762 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:64:in `resource_to_jbuilder'
[----] E, [2017-06-30T03:38:45.014877 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:39:in `block (2 levels) in collection_to_jbuilder'
[----] E, [2017-06-30T03:38:45.014979 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:298:in `block (2 levels) in _map_collection'
[----] E, [2017-06-30T03:38:45.015075 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:305:in `_scope'
[----] E, [2017-06-30T03:38:45.015187 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:298:in `block in _map_collection'
[----] E, [2017-06-30T03:38:45.015296 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:297:in `collect'
[----] E, [2017-06-30T03:38:45.015419 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:297:in `each'
[----] E, [2017-06-30T03:38:45.015545 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:297:in `map'
[----] E, [2017-06-30T03:38:45.015644 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:297:in `_map_collection'
[----] E, [2017-06-30T03:38:45.015739 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:188:in `array!'
[----] E, [2017-06-30T03:38:45.015850 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:34:in `block in set!'
[----] E, [2017-06-30T03:38:45.015948 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:305:in `_scope'
[----] E, [2017-06-30T03:38:45.016042 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:34:in `set!'
[----] E, [2017-06-30T03:38:45.016136 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:66:in `method_missing'
[----] E, [2017-06-30T03:38:45.016253 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:37:in `block in collection_to_jbuilder'
[----] E, [2017-06-30T03:38:45.016351 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/jbuilder-2.5.0/lib/jbuilder.rb:18:in `initialize'
[----] E, [2017-06-30T03:38:45.016444 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:31:in `new'
[----] E, [2017-06-30T03:38:45.016556 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:31:in `collection_to_jbuilder'
[----] E, [2017-06-30T03:38:45.016676 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/renderer.rb:8:in `render_collection'
[----] E, [2017-06-30T03:38:45.016770 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /var/www/miq/vmdb/app/controllers/api/base_controller/generic.rb:20:in `index'
[----] E, [2017-06-30T03:38:45.016864 #3100:182fc5c] ERROR -- : <API> MIQ(Api::ServicesController.api_error) /opt/rh/cfme-gemset/gems/actionpack-5.0.3/lib/action_controller/metal/basic_implicit_render.rb:4:in `send_action'


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
5.8.1


How reproducible:
-----------------
Unsure


Steps to Reproduce:
------------------
1.
2.
3.


Actual results:
---------------
NoMethodError in evm.log


Expected results:
-----------------
No errors


Additional info:
----------------
Comment 2 Jillian Tullo 2017-07-05 13:18:47 EDT

*** This bug has been marked as a duplicate of bug 1461939 ***

Note You need to log in before you can comment on or make changes to this bug.