Bug 1467545 - RHEL7.4 with VDSM3.6 - vds::(getHardwareInfo) failed to retrieve hardware info
RHEL7.4 with VDSM3.6 - vds::(getHardwareInfo) failed to retrieve hardware info
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.10
Unspecified Unspecified
high Severity high
: ovirt-3.6.12
: ---
Assigned To: Irit Goihman
David Necpal
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 03:43 EDT by Avihai
Modified: 2017-07-27 13:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 13:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (459.94 KB, application/x-gzip)
2017-07-04 03:43 EDT, Avihai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79020 ovirt-3.6 MERGED dmidecode: collect only system info 2017-07-05 05:40 EDT
Red Hat Product Errata RHBA-2017:1824 normal SHIPPED_LIVE vdsm 3.6.12 bug fix and enhancement update 2017-07-27 17:38:27 EDT

  None (edit)
Description Avihai 2017-07-04 03:43:04 EDT
Created attachment 1294102 [details]
vdsm log

Description of problem:
Running vdsClient -s 0 getVdsHardwareInfo fails with VDSM exeptions


Version-Release number of selected component (if applicable):
Engine:3.6.12-1
VDSM:vdsm-4.17.41-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.connect to a 3.6 on rhel7.4 host & run :

root@lynx20 vdsm]# vdsClient -s 0 getVdsHardwareInfo


Actual results:
you will get a failure message:
Failed to read hardware information

On VDSM log you'll see:
        
Thread-28059::DEBUG::2017-07-03 17:22:03,773::bindingxmlrpc::1273::vds::(wrapper) client [127.0.0.1]::call getHardwareInfo with () {}
Thread-28059::ERROR::2017-07-03 17:22:03,804::API::1350::vds::(getHardwareInfo) failed to retrieve hardware info
Traceback (most recent call last):
  File "/usr/share/vdsm/API.py", line 1347, in getHardwareInfo
    hw = supervdsm.getProxy().getHardwareInfo()
  File "/usr/share/vdsm/supervdsm.py", line 50, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>
    **kwargs)
  File "<string>", line 2, in getHardwareInfo
  File "/usr/lib64/python2.7/multiprocessing/managers.py", line 773, in _callmethod
    raise convert_to_error(kind, result)
IndexError: list assignment index out of range

Expected results:
The command should work.

Additional info:
Issue occurred only with RHEL7.4 + VDSM 3.6
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-05 04:10:05 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 6 David Necpal 2017-07-17 07:57:03 EDT
Verified on 7.4 public beta

# rpm -q vdsm
vdsm-4.17.42-1.el7ev.noarch


# vdsClient -s 0 getVdsHardwareInfo
	systemFamily = 'Red Hat Enterprise Linux'
	systemManufacturer = 'Red Hat'
	systemProductName = 'RHEV Hypervisor'
        ...
Comment 8 errata-xmlrpc 2017-07-27 13:38:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1824

Note You need to log in before you can comment on or make changes to this bug.