Bug 1467551 - default value for openshift_service_catalog_image_prefix are set incorrectly
default value for openshift_service_catalog_image_prefix are set incorrectly
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 03:57 EDT by Johnny Liu
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2017-07-04 03:57:43 EDT
Description of problem:
In roles/openshift_service_catalog/templates/api_server.j2, it is trying to use the following image:
<--snip-->
        image: {{ openshift_service_catalog_image_prefix }}service-catalog:{{ openshift_service_catalog_image_version }}
<--snip-->

In roles/openshift_service_catalog/tasks/install.yml,
<--snip-->
- name: Set service_catalog image facts
  set_fact:
    openshift_service_catalog_image_prefix: "{{ openshift_service_catalog_image_prefix | default(__openshift_service_catalog_image_prefix) }}"
    openshift_service_catalog_image_version: "{{ openshift_service_catalog_image_version | default(__openshift_service_catalog_image_version) }}"
<--snip-->

In roles/openshift_service_catalog/vars/openshift-enterprise.yml,
<--snip-->
__openshift_service_catalog_image_prefix: "registry.access.redhat.com/openshift3/"
__openshift_service_catalog_image_version: "3.6.0"
<--snip-->

That means catalog image path would be like:
registry.access.redhat.com/openshift3/service-catalog:3.6.0

While as far as I know, the image path would be like openshift3/ose-service-catalog, because I only could get openshift3/ose-service-catalog from OSBS.

So suggest the default value for __openshift_service_catalog_image_prefix should be set to "registry.access.redhat.com/openshift3/ose-"


Version-Release number of selected component (if applicable):
openshift-ansible-roles-3.6.132-1.git.0.0d0f54a.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Scott Dodson 2017-07-05 09:55:58 EDT
https://github.com/openshift/openshift-ansible/pull/4664 will fix the prefix but we don't have '3.6.0' as a tag.

So I've added 'v3.6' to the additional tags for the build and I think we should switch to using that.

https://github.com/openshift/openshift-ansible/pull/4679
Comment 4 Johnny Liu 2017-07-05 23:24:04 EDT
PR seem good to me, but I have one more request, is it possible to remove "registry.access.redhat.com/" from __openshift_service_catalog_image_prefix, so that allow user to easy to pull image from different registry according to openshift_docker_additional_registries setting, especially for QE's testing.
Comment 5 Johnny Liu 2017-07-06 04:55:29 EDT
@scott, I saw you also committed ab749692e5136b6ec05c647a04cc4e3e39a663eb for fully qualify ocp ansible_service_broker_image_prefix, if possible, could you revert it. I like the original behavior for the reason just like comment 4.
Comment 6 Scott Dodson 2017-07-06 08:00:06 EDT
We use a fully qualified prefix in metrics, logging, and registry-console. We're also trying to move away from relating on the --additional-registries behavior because it produces unpredictable results in a scenario where your additional registries happen to be down you may retrieve content from another registry.
Comment 7 Johnny Liu 2017-07-07 00:00:54 EDT
Verified this bug with openshift-ansible-3.6.135-1.git.0.5533fe3.el7.noarch.rpm, and PASS.
Comment 9 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.