Bug 146758 - Cannot unhide rows in calc
Cannot unhide rows in calc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 07:31 EST by JLapham
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 06:09:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JLapham 2005-02-01 07:31:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
If you hide a row in calc, you cannot later show the hidden row.  Columns work fine, this problem is only with rows.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-2.5.fc3

How reproducible:
Always

Steps to Reproduce:
1.highlight row #5 in an empty calc spreadsheet
2.In the pulldown menus: (Format -> Rows -> Hide) row #5 is now hidden
3.highlight rows #4 and #6
4.In the pulldown menus: (Format -> Rows -> Show) row #5 remains hidden

  

Actual Results:  Row # 5 is not shown

Expected Results:  Row #5 should be shown

Additional info:

You can repeat the above steps for a colummn to see how it should work.  I mark this as a "loss of data" bug because I have data that I cannot access in my spreadsheets, hidden behind un-show-able rows!!!
Comment 1 Marco Colombo 2005-02-02 06:38:49 EST
It happens here, too.
openoffice.org-1.1.3-2.5.fc3
Comment 2 Adam Batkin 2005-02-10 00:00:45 EST
See also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=289013

Temporary workaround: Copy the row previous and the row following to the
clipboard, then paste back in somewhere else. The hidden rows were copied/pasted
along with the two visible ones.

I couldn't find anything in the OOo bugtracker but didn't think it appropriate
to file something there as I'm not running their latest version (1.1.4 as of
today, compared to my openoffice.org-1.1.3-2.5.fc3)
Comment 3 JLapham 2005-02-10 05:44:28 EST
Thanks for the workaround Adam!  At least I can get to the data now.

I'm pretty sure this bug is due to some RH patch, I tried an official OOo
release a few months ago (1.1.3 as I recall) and I do not remember seeing this
problem.
Comment 4 Dan Williams 2005-02-10 07:47:55 EST
Technically yes it is a Red Hat patch, I patched the Novell patch for this in
our  1.1.2 version, but it seems to have broken again even though the patch has
not changed.
Comment 5 Arkadiusz Miskiewicz 2005-02-19 07:50:18 EST
It's fixed on 1.3 branch of ooo-build.
Comment 6 Dan Williams 2005-03-01 12:33:00 EST
will be fixed in next update (1.1.3-7)
Comment 7 Caolan McNamara 2005-03-18 06:09:55 EST
looks good in 1.1.3-9

Note You need to log in before you can comment on or make changes to this bug.