Bug 1467582 - opstools server deployment fails using opstools-ansible.
opstools server deployment fails using opstools-ansible.
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: opstools-ansible (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Martin Magr
Leonid Natapov
: Tracking
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 05:25 EDT by Matthias Runge
Modified: 2017-11-16 09:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-16 09:27:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2017-07-04 05:25:45 EDT
Description of problem:
with a fresh checkout from Jul 04 2017:

TASK [sensu/server : Configure sensu checks] ***********************************
failed: [monitoring] (item=sensu-checks) => {"failed": true, "item": "sensu-checks", "msg": "KeyError: 'undefined variable: 0'"}
ok: [monitoring] => (item=sensu-haproxy-check)



I used ansible-playbook pyml -e config.yml

with
cat config.yml 
kibana_proxy_user: admin
kibana_proxy_pass: changeme
rabbitmq_server: localhost
grafana_server_address: 192.168.36.60
firewall_manage_rules: false


and inventory/hosts being
---------
monitoring ansible_host=192.168.36.60 ansible_user=centos ansible_become=true

[logging_hosts]

[am_hosts]
monitoring

[pm_hosts]

------------
Comment 1 Joachim von Thadden 2017-07-17 06:37:05 EDT
This is related to
https://github.com/ansible/ansible/issues/20063
and seems to be related to the ansible version used while templating. I had the same error using my Fedora 26 host with ansible-2.3.1.0-1.fc26.noarch.

As I am deploying this for OpenStack I successfully used ansible-2.2.1.0-1.el7.noarch on the Undercloud.
Comment 2 Matthias Runge 2017-07-17 07:31:58 EDT
Uhm, it seems that the referenced change in ansible did not fix the issue: https://github.com/ansible/ansible/commit/188c3c608afa74b80f1f9ead8c6cf2cc0d23391e
Comment 3 Matthias Runge 2017-07-17 07:36:43 EDT
There is also https://github.com/ansible/ansible/issues/23779
Comment 4 Leonid Natapov 2017-07-18 01:52:31 EDT
(In reply to Matthias Runge from comment #2)
> Uhm, it seems that the referenced change in ansible did not fix the issue:
> https://github.com/ansible/ansible/commit/
> 188c3c608afa74b80f1f9ead8c6cf2cc0d23391e

IS this something that we can fix or it's an ansible bug and we have to wait until it will be fixed ? We need to think about some workaround in order to get opstools server installed.
Comment 5 Joachim von Thadden 2017-07-18 09:26:34 EDT
The workaround is already there: we are using opstools for OpenStack and we can install it from the director via provided and working ansible....

ansible-2.2.1.0-1.el7.noarch : SSH-based configuration management, deployment, and task execution system
Source      : @rhel-7-server-openstack-10-rpms
Comment 6 Matthias Runge 2017-07-19 04:02:40 EDT
Ideally, you'd have the monitoring server deployed before installing the OpenStack environment.

#c5 is surely a workaround. I currently don't understand, why it was marked as fixed in https://github.com/ansible/ansible/commit/188c3c608afa74b80f1f9ead8c6cf2cc0d23391e but still happens.

The workaround for opstools-ansible would be to remove the includes, which is quite ugly. 

I consider this to be an ansible bug.
Comment 7 Leonid Natapov 2017-07-30 09:43:14 EDT
Hey, any update regarding this bug ? Still can't install opstools-ansible
Comment 9 Matthias Runge 2017-07-31 09:23:45 EDT
There is no change.
Comment 10 Matthias Runge 2017-08-09 03:56:12 EDT
Looking at this again, it seems to be an ansible upstream bug https://github.com/ansible/ansible/issues/20494
and there is a proposed fix for it
https://github.com/zmedico/ansible/commit/db6966969ff437bf7f7c9c7e474fc22a1d6131de
Comment 11 Matthias Runge 2017-08-09 04:13:11 EDT
The proposed fix in ansible fixes this issue here
Comment 12 Martin Magr 2017-11-16 09:27:32 EST
Works for me with ansible-2.4.1.0-1.el7ae.noarch

Note You need to log in before you can comment on or make changes to this bug.