Bug 1467592 - SELinux is preventing sh from 'search' accesses on the directory /var/lib/sss.
SELinux is preventing sh from 'search' accesses on the directory /var/lib/sss.
Status: CLOSED DUPLICATE of bug 1456241
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:94588c00c0bc2a5e7b12a866eed...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 05:55 EDT by Hedayat Vatankhah
Modified: 2017-08-15 23:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 23:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2017-07-04 05:55:42 EDT
Description of problem:
SELinux is preventing sh from 'search' accesses on the directory /var/lib/sss.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sh should be allowed search access on the sss directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sh' --raw | audit2allow -M my-sh
# semodule -X 300 -i my-sh.pp

Additional Information:
Source Context                system_u:system_r:l2tpd_t:s0
Target Context                system_u:object_r:sssd_var_lib_t:s0
Target Objects                /var/lib/sss [ dir ]
Source                        sh
Source Path                   sh
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           sssd-common-1.15.2-5.fc26.x86_64
Policy RPM                    selinux-policy-3.13.1-257.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.5-300.fc26.x86_64 #1 SMP Wed
                              Jun 14 19:16:35 UTC 2017 x86_64 x86_64
Alert Count                   12
First Seen                    2017-07-03 09:39:22 +0430
Last Seen                     2017-07-03 09:39:27 +0430
Local ID                      96446d0e-af7e-4b4a-8697-c12dd2cda33d

Raw Audit Messages
type=AVC msg=audit(1499058567.131:1759): avc:  denied  { search } for  pid=22490 comm="sh" name="sss" dev="sda5" ino=1048774 scontext=system_u:system_r:l2tpd_t:s0 tcontext=system_u:object_r:sssd_var_lib_t:s0 tclass=dir permissive=0


Hash: sh,l2tpd_t,sssd_var_lib_t,dir,search

Version-Release number of selected component:
selinux-policy-3.13.1-257.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64
type:           libreport
Comment 1 Christopher Tubbs 2017-08-15 23:34:41 EDT
Looks like duplicate of bz#1456241

*** This bug has been marked as a duplicate of bug 1456241 ***

Note You need to log in before you can comment on or make changes to this bug.