Bug 14676 - Ensoniq Soundscape S2000 ISA MIDI Doesn't Work
Ensoniq Soundscape S2000 ISA MIDI Doesn't Work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-26 15:12 EDT by Dick Thompson
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 09:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dick Thompson 2000-07-26 15:12:01 EDT
See 4Front Open Sound notes on Ensoniq Soundscape S-2000 ISA requirements, 
and free Ensoniq module to make the soundcard work properly.

sndconfig allows assignment of proper MIDI and wave IRQ, DMA, and base 
addresses. No entries are provided for the card's SoundBlaster emulation.

After selection of proper system resources, sndconfig's .wav test works 
OK; MIDI test fails with a note that the sequencer failed.

Card works fine with Windows, any flavor, or MS-DOS 6.22 forward.

Card programmable parameters set up with Ensoniq MS-DOS software to be the 
same as those supposedly set up by sndconfig.

Punch line: 4Front Open Sound uses free Ensoniq Linux drivers to make 
Soundscape S-2000 ISA cards work. How about Red Hat doing the same?

Red Hat claims it supports this sound card. At present, it doesn't.

Dick Thompson
Comment 1 Bill Nottingham 2000-07-26 15:21:13 EDT
I'm not sure what you mean by 'free linux drivers'; there's
the sound card's firmware, but that comes with the card
itself; we aren't going to ship that.
Comment 2 Dick Thompson 2000-07-26 15:42:25 EDT
The "free Linux drivers" are in a module named sndscape.co0, available free 
from both 4Front Open Sound and Ensoniq.

Because I'm a REAL Linux newbie, I have no idea how to install this module and 
any other software upon which it depends.

The point is that Red Hat claims RH Linux 6.2 supports this sound card, and it 
doesn't. Red Hat's tech support has made several suggestions, but none has 
helped.

I believe it's a bug in the soundscape software included with 6.2; a bug which 
others in the Linux community have found a way to fix; and a bug for which the 
bug fix is free.

Red Hat should make the fix available to purchasers of it's product in a form 
which those purchasers can easily incorporate into their operating systems, 
such that the product in fact supports hardware Red Hat claims it supports.
Comment 3 Wes Gilster 2001-08-20 09:46:08 EDT
I'm not sure what Red Hat is doing about this bug, but perhaps it might 
interest them in knowing that others are having the same problem.  I am using 
V7.1 and have had a very similar problem.  Plays the audio, doesn't play midi.
Comment 4 Bill Nottingham 2002-01-22 23:53:56 EST
We don't plan to ship the firmware for the card with the OS, that should come
with the card.

Note You need to log in before you can comment on or make changes to this bug.