This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1467621 - build: make gf_attach available in glusterfs-server
build: make gf_attach available in glusterfs-server
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Milind Changire
nchilaka
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-07-04 07:34 EDT by Milind Changire
Modified: 2017-09-21 01:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-33
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 01:02:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 nchilaka 2017-07-17 03:00:42 EDT
on_qa validation:
have seen that gf_attach function has been moved to glusterfs-server package in 3.8.4-18-33

[root@dhcp35-45 3.8.4-33]# rpm -qlp glusterfs-server-3.8.4-33.el7rhgs.x86_64.rpm |grep gf_attach
/usr/sbin/gf_attach
[root@dhcp35-45 3.8.4-33]# rpm -qa|grep ^C
[root@dhcp35-45 3.8.4-33]# rpm -qa glusterfs-fuse-3.8.4-33.el7rhgs.x86_64.rpm |grep gf_attac



also i am able to detach brick using gf_attach

root@dhcp35-45 ~]# #gf_attach -d uds_path brick_path 
[root@dhcp35-45 ~]# gf_attach -d /rhs/brick9/vol_9
Usage: gf_attach uds_path volfile_path (to attach)
       gf_attach -d uds_path brick_path (to detach)
[root@dhcp35-45 ~]# gf_attach -d /var/run/gluster/f3678cbb26724c43ffe643412d02da45.socket /rhs/brick9/vol_9
connected
OK
[root@dhcp35-45 ~]# gluster v status vol_9
Status of volume: vol_9
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.35.45:/rhs/brick9/vol_9         N/A       N/A        N       N/A  
Brick 10.70.35.130:/rhs/brick9/vol_9        49152     0          Y       23388
Brick 10.70.35.122:/rhs/brick9/vol_9        49152     0          Y       7533 
Self-heal Daemon on localhost               N/A       N/A        Y       28408
Self-heal Daemon on 10.70.35.122            N/A       N/A        Y       8593 
Self-heal Daemon on 10.70.35.130            N/A       N/A        Y       24449
Self-heal Daemon on 10.70.35.23             N/A       N/A        Y       13582
Self-heal Daemon on 10.70.35.112            N/A       N/A        Y       22793
Self-heal Daemon on 10.70.35.138            N/A       N/A        Y       6911 
 
Task Status of Volume vol_9
------------------------------------------------------------------------------
There are no active volume tasks
 
[root@dhcp35-45 ~]# gluster v status vol_10
Status of volume: vol_10
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.35.45:/rhs/brick10/vol_10       49152     0          Y       26613
Brick 10.70.35.130:/rhs/brick10/vol_10      49152     0          Y       23388
Brick 10.70.35.122:/rhs/brick10/vol_10      49152     0          Y       7533 
Self-heal Daemon on localhost               N/A       N/A        Y       28408
Self-heal Daemon on 10.70.35.122            N/A       N/A        Y       8593 
Self-heal Daemon on 10.70.35.23             N/A       N/A        Y       13582
Self-heal Daemon on 10.70.35.138            N/A       N/A        Y       6911 
Self-heal Daemon on 10.70.35.130            N/A       N/A        Y       24449
Self-heal Daemon on 10.70.35.112            N/A       N/A        Y       22793
 
Task Status of Volume vol_10
------------------------------------------------------------------------------
There are no active volume tasks
 
[root@dhcp35-45 ~]# rpm -q^C
[root@dhcp35-45 ~]# gluster v heal vol_9 info
Brick 10.70.35.45:/rhs/brick9/vol_9
Status: Transport endpoint is not connected
Number of entries: -

Brick 10.70.35.130:/rhs/brick9/vol_9
/ 
/.trashcan 
/f1 
Status: Connected
Number of entries: 3

Brick 10.70.35.122:/rhs/brick9/vol_9
/ 
/.trashcan 
/f1 
Status: Connected
Number of entries: 3

[root@dhcp35-45 ~]# gluster v heal vol_10 info
Brick 10.70.35.45:/rhs/brick10/vol_10
Status: Connected
Number of entries: 0

Brick 10.70.35.130:/rhs/brick10/vol_10
Status: Connected
Number of entries: 0

Brick 10.70.35.122:/rhs/brick10/vol_10
Status: Connected
Number of entries: 0





Hence moving to verified
Comment 7 errata-xmlrpc 2017-09-21 01:02:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.