Bug 1467624 - Not informative error message when Hawkular URL is "" [NEEDINFO]
Not informative error message when Hawkular URL is ""
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.6.0
x86_64 Linux
unspecified Severity low
: GA
: cfme-future
Assigned To: Barak
Jaroslav Henner
container:ui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 07:46 EDT by Jaroslav Henner
Modified: 2017-12-26 10:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-26 10:22:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Container Management
fsimonce: needinfo? (jhenner)


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2017-07-04 07:46:31 EDT
Description of problem:
When Hawkular URL is set to "" when adding the openshift provider, the error message after clicking the Validate button says:

Credential validation was not successful: 

So it is missing the reason of failure.


Version-Release number of selected component (if applicable):
cfme-rhos-5.6.4.2-1.x86_64.qcow2
cfme-rhos-5.7.3.2-1.x86_64.qcow2

How reproducible:
always

Steps to Reproduce:
1. Fill hawkular URL with ""
2. Click on validate


Actual results:
Error message specified in the description of this bug appears.

Expected results:
Validate not clickable and/or informative error message

Additional info:
Comment 2 Jaroslav Henner 2017-07-04 08:15:55 EDT
This also happens when the hostname and port is set so when connection attempt is made, the connection is reset.
Comment 3 Federico Simoncelli 2017-10-05 10:23:13 EDT
Can you try to reproduce with the latest 5.8 release?
Comment 4 Barak 2017-12-26 10:22:38 EST
This issue among other issues in the add provider page were fixed (and verified) for 5.9, hence moving to CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.