Bug 1467625 - [Samba-SELINUX] avc denied messages are seen in audit.log for path "/run/ctdb/ctdbd.pid"
[Samba-SELINUX] avc denied messages are seen in audit.log for path "/run/ctdb...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: ctdb (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Anoop C S
Vivek Das
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-07-04 07:48 EDT by Vivek Das
Modified: 2017-09-21 00:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: samba-4.6.3-5.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:47:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 12898 None None None 2017-07-12 03:41 EDT

  None (edit)
Description Vivek Das 2017-07-04 07:48:29 EDT
Description of problem:

Over a RHEL 7.4 , 3.3.0 samba-cdtb setup avc denied messages as shown below are seen. 
There is no functional issue seen as such.

type=AVC msg=audit(1499168563.384:321703): avc:  denied  { write } for  pid=7924 comm="ip" path="/run/ctdb/ctdbd.pid" dev="tmpfs" ino=34967954 scontext=system_u:system_r:ifconfig_t:s0 tcontext=system_u:object_r:ctdbd_var_run_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-165.el7.noarch
samba-4.6.3-3.el7rhgs.x86_64
glusterfs-3.8.4-32.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Over samba ctdb setup run any IOs
2. Check for avc denied in audit.log
3.

Actual results:
Getting avc denied text

Expected results:
Should not get any avc denied

Additional info:
type=AVC msg=audit(1499168563.384:321703): avc:  denied  { write } for  pid=7924 comm="ip" path="/run/ctdb/ctdbd.pid" dev="tmpfs" ino=34967954 scontext=system_u:system_r:ifconfig_t:s0 tcontext=system_u:object_r:ctdbd_var_run_t:s0 tclass=file
Comment 4 Vivek Das 2017-07-10 00:26:22 EDT
No functional issues are seen as of now.
Comment 5 Anoop C S 2017-07-14 01:51:37 EDT
Fixed upstream:

https://git.samba.org/?p=samba.git;a=commit;h=3e85cbfd7541d8f30ce1f3244ebcc44332b394fe

see Samba upstream bug in 'External trackers' for more details.
Comment 8 Vivek Das 2017-07-24 02:58:08 EDT
No AVC denied messages are seen so far with the latest build i.e samba-4.6.3-5.el7rhgs.
Marking this as verified.
Comment 10 errata-xmlrpc 2017-09-21 00:47:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2780

Note You need to log in before you can comment on or make changes to this bug.