Bug 1467643 - mariadb library change causes zabbix FTBFS
mariadb library change causes zabbix FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zabbix (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1467297
  Show dependency treegraph
 
Reported: 2017-07-04 08:30 EDT by Augusto Caringi
Modified: 2017-07-14 12:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 12:14:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Augusto Caringi 2017-07-04 08:30:12 EDT
Trying to build zabbix with the new version of MariaDB 10.2 causes an error in configure script:

configure: error: Not found mysqlclient library

Upstream is already aware of this problem (patch available):

https://support.zabbix.com/browse/ZBX-12232
https://support.zabbix.com/browse/ZBX-11335

We are tracking all the possible problems regarding this MariaDB upgrade in the bug 1467297.

Copr build: https://copr.fedorainfracloud.org/coprs/g/db-sig/mariadb-10.2/package/zabbix/
Comment 1 Adam Williamson 2017-07-13 20:58:11 EDT
I've committed a change which ought to fix this, now. Can't build, yet, because there's a mess going on with the s390 builders which is preventing anyone from building anything successfully at present.
Comment 2 Adam Williamson 2017-07-14 12:14:34 EDT
I sent the build now: https://koji.fedoraproject.org/koji/buildinfo?buildID=918810

Note You need to log in before you can comment on or make changes to this bug.