Bug 1467644 - VM reconfigure quota exceed messages does not display the proper requested quota values.
VM reconfigure quota exceed messages does not display the proper requested qu...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: William Fitzgerald
Aziza Karol
reconfigure:quota
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 08:33 EDT by Aziza Karol
Modified: 2017-07-25 02:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 10:43:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quota exceed msg (112.89 KB, image/png)
2017-07-04 08:33 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2017-07-04 08:33:20 EDT
Created attachment 1294196 [details]
quota exceed msg

Description of problem:


Version-Release number of selected component (if applicable):
5.8.1.0.20170623170756_3ed4411  

How reproducible:
100%

Steps to Reproduce:
1.Apply quota settings for tenant.
2.Reconfigure the VM to be over those quota limits


Actual results:
VM reconfigure quota exceed messages does not display the proper requested quota values. for example while re configuring a VM values set were:
memory-8GB,processor-4,disk added-6GB but its showing up wrong values in the quota exceeded messages.  


See attached screenshot.
Request exceeds maximum allowed for the following: (cpu - Used: 51 plus requested: 3 exceeds quota: 1) (memory - Used: 85.3 GB plus requested: 6 GB exceeds quota: 1 GB) (storage - Used: 687 GB plus requested: 6 GB exceeds quota: 1 GB) 


Expected results:
quota exceed messages should display proper requested values

Additional info:
Comment 2 Aziza Karol 2017-07-05 07:30:47 EDT
VM reconfigure quota exceed messages are also inconsistent for user and group quota.
Comment 3 William Fitzgerald 2017-07-05 10:24:03 EDT
Aziza,

Is your appliance available ?
Comment 5 William Fitzgerald 2017-07-17 13:58:40 EDT
The values used in quota calculations for VM reconfigure are the difference between the VMs current configuration and what is currently requested.

For example, if a machine has 4.gb of storage and is reconfigured for 6.gb, The quota value will be 2.gb.

Does this explain the differences in the reported quota values? If not, can I access your test environment?
Comment 7 William Fitzgerald 2017-07-20 10:56:57 EDT
Aziza,

Your appliance is already over quota for storage so if you try to reconfigure and add any amount, you will exceeded quota.  You have already used 1.56 TB storage which exceeds 1 GB.  You are trying to add 128 MB of storage and you are already over.

This looks like it is working.

Let me know if you have any other questions.

Thanks

Billy
Comment 8 Aziza Karol 2017-07-24 01:11:18 EDT
Hey Billy,

Yes It's working. Thanks for the info.

~Aziza
Comment 9 William Fitzgerald 2017-07-24 10:09:21 EDT
Aziza,

Can I close this ticket ?

Please let me know.

Thanks

Billy
Comment 10 Aziza Karol 2017-07-24 10:27:32 EDT
Hi Billy,

You can close it.

Thanks,
Aziza

Note You need to log in before you can comment on or make changes to this bug.