Bug 1467649 - 'openstack overcloud update ...' fails when yum is locked on an overcloud node
'openstack overcloud update ...' fails when yum is locked on an overcloud node
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
9.0 (Mitaka)
All Linux
medium Severity medium
: zstream
: 9.0 (Mitaka)
Assigned To: Emilien Macchi
Raviv Bar-Tal
: TestOnly, Triaged, ZStream
Depends On:
Blocks: 1471720 1471721
  Show dependency treegraph
 
Reported: 2017-07-04 08:41 EDT by Paul Needle
Modified: 2018-07-05 08:27 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-2.0.0-59.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1471720 (view as bug list)
Environment:
Last Closed: 2018-07-05 08:26:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1704131 None None None 2017-07-13 09:23 EDT
Red Hat Knowledge Base (Solution) 3113401 None None None 2017-07-13 05:11 EDT
OpenStack gerrit 483390 None None None 2017-07-13 09:56 EDT
Red Hat Product Errata RHBA-2018:2140 None None None 2018-07-05 08:27 EDT

  None (edit)
Description Paul Needle 2017-07-04 08:41:46 EDT
Description of problem:

'openstack overcloud update ...' fails when yum is already locked on an overcloud node. The overcloud update subsequently times out waiting for yum_update.sh to obtain a list of packages requiring an update on that node.

Version-Release number of selected component (if applicable):

* Red Hat OpenStack Platform 9.
* RHEL 7.
* yum-3.4.3-150.el7.

How reproducible:

Every time.

Steps to Reproduce:

1. On an overcloud node, trigger a scenario where yum is locked. In a real world use-case, this could be due to a previous issue being experienced on an overcloud node.

2. Run 'openstack overcloud update ...'.

Actual results:

The overcloud update times out when the yum_update.sh script tries to obtain a list of packages requiring update from the node which is locked.

Expected results:

For the overcloud update sequence to handle this situation effectively, perhaps through clear error messaging or by handling of the yum lock.
Comment 1 Marios Andreou 2017-07-17 06:35:32 EDT
clones: 
OSP9 @ https://bugzilla.redhat.com/show_bug.cgi?id=1467649 
OSP10@ https://bugzilla.redhat.com/show_bug.cgi?id=1471720
OSP11@ https://bugzilla.redhat.com/show_bug.cgi?id=1471721

No BZ needed for OSP12 since the minor update workflow there is different. However  the files do still exist on master and we landed this one first https://review.openstack.org/#/c/483390/ (even though it won't be used by master/Pike) and then backported to stable/newton since that is the oldest we have right now. Will have to be d/stream for OSP9 which is what this bug was opened for in the first place. Once stable/newton merges I will post the d/stream review and attach to the OSP9 clone.
Comment 11 errata-xmlrpc 2018-07-05 08:26:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2140

Note You need to log in before you can comment on or make changes to this bug.