Bug 1467694 - not clear how to specify credentials as compound set when adding providers using REST API [NEEDINFO]
not clear how to specify credentials as compound set when adding providers us...
Status: CLOSED DUPLICATE of bug 1467692
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Martin Kourim
api:rest:provider
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 11:55 EDT by Martin Kourim
Modified: 2017-07-06 10:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 10:28:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jtullo: needinfo? (mkourim)


Attachments (Terms of Use)

  None (edit)
Description Martin Kourim 2017-07-04 11:55:58 EDT
Neither the documentation nor the API describe how credentials are mapped to endpoints when creating a new provider using the REST API and specifying credentials as compound set.

There's no information on what values of "auth_type" are valid and how "auth_type" values are related to endpoints.

http://manageiq.org/docs/reference/latest/api/reference/providers#specifying-credentials
Comment 2 Jillian Tullo 2017-07-05 13:43:54 EDT
Hi Martin--

Have you seen the "Connection Configurations" section? http://manageiq.org/docs/reference/latest/api/reference/providers#specifying-connection-configurations ... there is also a PR outstanding for another addition: https://github.com/ManageIQ/manageiq_docs/pull/406/files

If that is not what you are referring to, do you have a more specific example? I'd be happy to make another addition 

Thank you,
Jillian
Comment 3 Gregg Tanzillo 2017-07-06 10:28:37 EDT

*** This bug has been marked as a duplicate of bug 1467692 ***

Note You need to log in before you can comment on or make changes to this bug.