Bug 1467703 - mariadb library upgrade to 10.2 causes dspam FTBFS
mariadb library upgrade to 10.2 causes dspam FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dspam (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nathanael Noblet
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1467297
  Show dependency treegraph
 
Reported: 2017-07-04 12:42 EDT by Augusto Caringi
Modified: 2017-07-17 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 12:35:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow compilation of dspam with MariaDB 10.2 (2.28 KB, patch)
2017-07-04 12:42 EDT, Augusto Caringi
no flags Details | Diff

  None (edit)
Description Augusto Caringi 2017-07-04 12:42:28 EDT
Created attachment 1294295 [details]
Patch to allow compilation of dspam with MariaDB 10.2

Trying to build dspam with the new version of MariaDB 10.2 causes an error in the configure script:

configure: error: in `/builddir/build/BUILD/dspam-3.10.2':
configure: error: Unsupported version of MySQL (no PROTOCOL_VERSION or ER_LOCK_DEADLOCK or ER_LOCK_WAIT_TIMEOUT or ER_LOCK_OR_ACTIVE_TRANSACTION or CR_ERROR_FIRST defined)

The cause is that CR_ERROR_FIRST is no longer present in this new version of the library. I attached a patch proposal to fix the problem.

We are tracking all the possible problems regarding this MariaDB upgrade in the bug 1467297.

Copr build: https://copr.fedorainfracloud.org/coprs/g/db-sig/mariadb-10.2/package/dspam/
Comment 1 Nathanael Noblet 2017-07-04 12:48:35 EDT
I don't mind applying the patch. I don't use this project much anymore so I'm wondering why all the failures are in the configure/m4 files. Why test for this but not use anything in C? Should this really be all there is to it?
Comment 2 Augusto Caringi 2017-07-10 12:23:54 EDT
(In reply to Nathanael Noblet from comment #1)
> I don't mind applying the patch. I don't use this project much anymore so
> I'm wondering why all the failures are in the configure/m4 files. Why test
> for this but not use anything in C? Should this really be all there is to it?

Good question... But it seems that the only define that is tested and not used is CR_ERROR_FIRST, and it's exactly with this define the problem.
What do the developers say about that?
Comment 3 Nathanael Noblet 2017-07-15 23:44:37 EDT
Unfortunately, upstream development is basically dead. It was a fantastic spam system. No idea why it never got more popular than spam assassin and friends. I've applied the patch and sent a build.
Comment 4 Nathanael Noblet 2017-07-17 12:35:13 EDT
The new build completed successfully.

Note You need to log in before you can comment on or make changes to this bug.