Bug 1467724 - Gradle builds stopped working since jna-4.4.0-2.fc27
Gradle builds stopped working since jna-4.4.0-2.fc27
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gradle (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On: 1469022
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 17:16 EDT by Mat Booth
Modified: 2017-07-22 05:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.13-9
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 06:30:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mat Booth 2017-07-04 17:16:11 EDT
See packages in koschei that build using gradle, for example spock:

https://apps.fedoraproject.org/koschei/package/spock?collection=f27

The error is:

Executing: gradle-local --no-daemon --offline -x javadoc build xmvnInstall
['gradle-local', '--no-daemon', '--offline', '-x', 'javadoc', 'build', 'xmvnInstall']
java.lang.IllegalArgumentException: Cannot find JAR 'jna.jar' required by module 'gradle-native' using classpath or distribution directory '/usr/share/gradle'

It looks like the jna.jar moved from /usr/share to /usr/lib and this broke the symlink in gradle.
Comment 1 Mikolaj Izdebski 2017-07-10 05:41:33 EDT
Fixed in gradle-2.13-9
Comment 2 Mikolaj Izdebski 2017-07-14 06:30:30 EDT
I believe that this bug is fixed in gradle-2.13-9,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=918484

Note You need to log in before you can comment on or make changes to this bug.