Bug 1467733 - hosted-engine-setup fails installing with static networking configuration for the engine VM
hosted-engine-setup fails installing with static networking configuration for...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network (Show other bugs)
2.1.3
Unspecified Unspecified
urgent Severity urgent (vote)
: ovirt-4.1.3
: ---
Assigned To: Simone Tiraboschi
Nikolai Sednev
: Regression, Triaged
Depends On:
Blocks: 1455606
  Show dependency treegraph
 
Reported: 2017-07-04 18:33 EDT by Simone Tiraboschi
Modified: 2017-07-06 09:11 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 09:11:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: blocker+
ylavi: testing_plan_complete?
ylavi: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79026 master MERGED Revert "plugins: cloud_init: support interfaces with dash" 2017-07-05 08:34 EDT
oVirt gerrit 79027 ovirt-hosted-engine-setup-2.1 MERGED Revert "plugins: cloud_init: support interfaces with dash" 2017-07-05 08:34 EDT

  None (edit)
Description Simone Tiraboschi 2017-07-04 18:33:37 EDT
Description of problem:
Since https://gerrit.ovirt.org/#/c/77882 and https://gerrit.ovirt.org/77904, hosted-engine-setup uses the code from ovirt-setup-lib to fetch the host address but hosted-engine-setup was waiting also for subnet mask length while ovirt-setup-lib code wasn't giving it back.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine-setup
2. choose static for the engine VM network
3.

Actual results:
2017-07-04 18:43:44,754+0200 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:204 DIALOG:SEND                 Please enter the IP address to be used for the engine VM []:
2017-07-04 18:43:57,962+0200 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:204 DIALOG:RECEIVE    192.168.1.207
2017-07-04 18:43:57,962+0200 ERROR otopi.plugins.gr_he_common.vm.cloud_init cloud_init._error_raise_retry:181 The Engine VM (192.168.1.207/32) and this host (192.168.1.107/32) will not be in the same IP subnet.
Static routing configuration are not supported on automatic VM configuration.


Expected results:
No errors there

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-04 18:41:19 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2017-07-04 18:41:19 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Nikolai Sednev 2017-07-05 14:46:43 EDT
I've successfully deployed SHE using static IP configuration option for HE-VM during SHE deployment.

 How should the engine VM network be configured (DHCP, Static)[DHCP]? Static
          Please enter the IP address to be used for the engine VM [10.35.72.1]: 10.35.72.51
[ INFO  ] The engine VM will be configured to use <IP of SHE-VM here>/24
          Please provide a comma-separated list (max 3) of IP addresses of domain name servers for the engine VM
          Engine VM DNS (leave it empty to skip) [<DNS server's IP taken from host's /etc/resolv.conf>]: <DNS server's IP addresses here>
          Add lines for the appliance itself and for this host to /etc/hosts on the engine VM?
          Note: ensuring that this host could resolve the engine VM hostname is still up to you
          (Yes, No)[No] yes
.
.
.
.
.
.
          |- [ INFO  ] Execution of setup completed successfully
          |- HE_APPLIANCE_ENGINE_SETUP_SUCCESS
[ INFO  ] Engine-setup successfully completed 
[ INFO  ] Engine is still unreachable
[ INFO  ] Engine is still not reachable, waiting...
[ INFO  ] Engine is still unreachable
[ INFO  ] Engine is still not reachable, waiting...
[ INFO  ] Engine replied: DB Up!Welcome to Health Status!
[ INFO  ] Acquiring internal CA cert from the engine
[ INFO  ] The following CA certificate is going to be used, please immediately interrupt if not correct:
[ INFO  ] Issuer: C=US, O=qa.lab.tlv.redhat.com, CN=nsednev-he-1.qa.lab.tlv.redhat.com.91210, Subject: C=US, O=qa.lab.tlv.redhat.com, CN=nsednev-he-1.qa.lab.tlv.redhat.com.91210, Fingerprint (SHA-1): 9FE8BA20E75996A2DC5202FDE68D71929D0E41C5
[ INFO  ] Connecting to the Engine
[ INFO  ] Waiting for the host to become operational in the engine. This may take several minutes...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] The VDSM Host is now operational
[ INFO  ] Saving hosted-engine configuration on the shared storage domain
[ INFO  ] Shutting down the engine VM
 INFO  ] Enabling and starting HA services
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20170705214610.conf'
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Hosted Engine successfully deployed



Works for me on these components on hosts:
qemu-kvm-rhev-2.9.0-14.el7.x86_64
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
mom-0.5.9-1.el7ev.noarch
ovirt-imageio-daemon-1.0.0-0.el7ev.noarch
ovirt-setup-lib-1.1.3-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-imageio-common-1.0.0-0.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
vdsm-4.19.20-1.el7ev.x86_64
ovirt-hosted-engine-ha-2.1.4-1.el7ev.noarch
libvirt-client-3.2.0-14.el7.x86_64
ovirt-hosted-engine-setup-2.1.3.3-1.el7ev.noarch
sanlock-3.5.0-1.el7.x86_64
ovirt-host-deploy-1.6.6-1.el7ev.noarch
Linux version 3.10.0-691.el7.x86_64 (mockbuild@x86-037.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) ) #1 SMP Thu Jun 29 10:30:04 EDT 2017
Linux 3.10.0-691.el7.x86_64 #1 SMP Thu Jun 29 10:30:04 EDT 2017 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.4 (Maipo)

Moving to verified.
Comment 4 Nikolai Sednev 2017-07-05 14:54:51 EDT
Engine was deployed using rhvm-appliance-4.1.20170627.0-1.el7.noarch.

Note You need to log in before you can comment on or make changes to this bug.