Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1467748 - qutebrowser-v1.0.3 is available
qutebrowser-v1.0.3 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qutebrowser (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Orsava
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 20:23 EDT by Upstream Release Monitoring
Modified: 2017-11-28 18:49 EST (History)
6 users (show)

See Also:
Fixed In Version: qutebrowser-1.0.3-2.fc27
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-28 18:49:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
specfile for qutebrowser v1.0.2 (5.88 KB, text/plain)
2017-10-24 08:47 EDT, Timothée Floure
no flags Details

  None (edit)
Description Upstream Release Monitoring 2017-07-04 20:23:57 EDT
Latest upstream release: v0.11.0
Current version/release in rawhide: 0.10.1-1.fc27
URL: http://www.qutebrowser.org

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/9759/
Comment 1 Upstream Release Monitoring 2017-07-04 20:24:03 EDT
Skipping the scratch build because an SRPM could not be built: ['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', u'/var/tmp/thn-egS5_k/qutebrowser.spec'] returned 1: error: line 26: Unknown tag: Recommends:	python3-cssutils
Comment 2 Timothée Floure 2017-10-10 12:41:13 EDT
Any news on this one ? I would be glad to help since it's a software I use a lot.
Comment 3 Timothée Floure 2017-10-12 07:30:06 EDT
Version 1.0.0 has been released a few hours ago : https://github.com/qutebrowser/qutebrowser/releases/tag/v1.0.0
Comment 4 Tomas Orsava 2017-10-19 12:22:49 EDT
Hi Timothee! I'll try to get to this next week, sadly I have too much on my plate right now and don't use qutebrowser anymore.

Would you be interested in becoming a co-maintainer of qutebrowser perhaps?
Comment 5 Timothée Floure 2017-10-19 13:11:16 EDT
I'm indeed interested by becoming a co-maintainer. I understand it's not your priority since you're not using it anymore.

I know the basics of rpm packaging and should be able to catch up.

Thank you !
Comment 6 Tomas Orsava 2017-10-19 13:14:37 EDT
Great! Are you already a Fedora packager (and do you have a FAS account [0])?

[0] https://fedoraproject.org/wiki/Account_System
Comment 7 Timothée Floure 2017-10-19 13:21:46 EDT
I already packaged a few things for myself, have a few things on copr and an ongoing official package review (still waiting for a sponsor).

My FAS account is fnux.
Comment 8 Upstream Release Monitoring 2017-10-19 20:47:06 EDT
Latest upstream release: v1.0.2
Current version/release in rawhide: 0.10.1-2.fc27
URL: http://www.qutebrowser.org

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/9759/
Comment 9 Upstream Release Monitoring 2017-10-19 20:47:10 EDT
Skipping the scratch build because an SRPM could not be built: ['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', u'/var/tmp/thn-lQYrbn/qutebrowser.spec'] returned 1: error: line 26: Unknown tag: Recommends:	python3-cssutils
Comment 10 Tomas Orsava 2017-10-20 05:45:11 EDT
Ah, great that you have some skills under your belt! So, we need you to find a sponsor to finish your official package review and then when you're in the packager group, we can get you onto qutebrowser!

Have you tried actively searching for a sponsor? [0]

[0] https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group
Comment 11 Timothée Floure 2017-10-20 06:13:11 EDT
The related package (gcolor3) review is somewhat waiting for upstream fo fix wayland support so it's going to take a while.

An other way would be to 'convince you to let me co-maintain the package and act as my mentor'. I can update the specfile for the new version(s) and have you review it.
Comment 12 Tomas Orsava 2017-10-20 07:11:19 EDT
Yeah, I read about that as well. A traditional review would be better, but if it's blocked by wayland let's try this way. I'll try to find a sponsor for this process and I'll let you know by next week.

In the meantime, you can update the spec file to the newest version and post it here for review.
Comment 13 Timothée Floure 2017-10-24 08:47 EDT
Created attachment 1342736 [details]
specfile for qutebrowser v1.0.2

Here an updated specfile for qutebrowser v1.0.2.

About the changelog :
%changelog
* Fri Oct 20 2017 Timothée Floure <timothee.floure@fnux.ch> - 1.0.2-1
- Rebased to 1.0.2
- Add the python3-attrs dependency                                          [1]
- Adapt the descriptions and dependencies to the QtWebEngine backend        [2]
- Remove the deprecated Group tag                                           [3]
- Package the quickstart.asciidoc and userscripts.asciidoc files            [4]

[1] Dependency added in qutebrowser v1.0.0
(https://www.qutebrowser.org/doc/changelog.html)
[2] QtWebEngine is the default backend since qutebrowser v1.0.0
(https://www.qutebrowser.org/doc/changelog.html)
[3] https://fedoraproject.org/wiki/RPMGroups
[4] We already package contributing.asciidoc and faq.asciidoc, it makes sense
to package quickstart.asciidoc and userscripts.asciidoc as well

I used this package for the last few days on my F26 laptop, and briefly
tested it in a F27 WorkStation VM : everything looks fine.
Comment 14 Miro Hrončok 2017-10-25 09:58:22 EDT
Tomas, I've sponsored fnux. Please provide guidance where needed. Timothée, use your powers wisely, feel free to reach to me any time.
Comment 15 Tomas Orsava 2017-10-25 12:32:07 EDT
(In reply to Miro Hrončok from comment #14)
> Tomas, I've sponsored fnux. Please provide guidance where needed. Timothée,
> use your powers wisely, feel free to reach to me any time.

Thank you, Miro!
Comment 16 Tomas Orsava 2017-10-25 12:40:28 EDT
So, Timothée, you should now be part of the packagers group!


For the spec file:
- You've added the dependencies on QtWebEngine, good!, however, the upstream changelog [0] says "QtWebKit (if new enough) should be changed to an optional dependency". So instead of omitting it, an optional dependency would be better.

- PKG-INFO is not documentation and does not belong to %doc.

- On the line where you added the new `python3-attrs` dependency, please follow the same spacing as other dependency lines to keep a consistent style.


What next:
Since you're a packager, I suggest you try to fork the qutebrowser repo on Pagure [1], and try to submit a pull request with your modified spec file.

If you encounter difficulties, feel free to contact me by email at torsava at redhat.com, or on IRC Freenode server: user torsava on the #fedora-python channel.


[0] https://www.qutebrowser.org/doc/changelog.html
[1] https://pagure.io/fedora-packager
Comment 17 Timothée Floure 2017-10-25 15:31:36 EDT
@churchyard : Thank you for sponsoring me !

I will take a look to the the 'official' workflow and submit a PR this weekend. 

About the specfile :
  * QtWebKit dependency : under a 'Suggests' tag ? [1]
  * PKG-INFO was already in %doc, but it's indeed weird. Was there any reason ?
  * python3-attrs spacing : I accidently used a space instead of a tab.

 [1] https://fedoraproject.org/wiki/Packaging:WeakDependencies
Comment 18 Tomas Orsava 2017-10-26 05:27:19 EDT
> I will take a look to the the 'official' workflow and submit a PR this
> weekend.

+1

> About the specfile :
>   * QtWebKit dependency : under a 'Suggests' tag ? [1]

Suggests is possible, though I think Recommends would be better because Suggests is currently ignored by dnf.

>   * PKG-INFO was already in %doc, but it's indeed weird. Was there any
> reason ?

Oops, my mistake! :) I put it into a few spec files before I learned better. Since we're updating the spec, I recommend taking it out.

>   * python3-attrs spacing : I accidently used a space instead of a tab.

Happens to everyone.

 
>  [1] https://fedoraproject.org/wiki/Packaging:WeakDependencies
Comment 19 Ankur Sinha (FranciscoD) 2017-10-28 11:26:27 EDT
Really looking forward to this update. 

I maintain a COPR here where I build git snapshots - on a weekly basis if possible - to keep up with the new stuff as it comes out freshly baked. 

https://copr.fedorainfracloud.org/coprs/ankursinha/qutebrowser/

I'd be happy to help with this too if needed.

Thanks for working on this :)
Comment 20 Tomas Orsava 2017-10-31 06:02:22 EDT
Further discussion in a Pagure PR: https://src.fedoraproject.org/rpms/qutebrowser/pull-request/1

And cool, Ankur, about the git snapshots, keep it up! So far I think Timothee has got this, however, thank you for your interest!
Comment 21 Florian Bruhin 2017-11-03 04:25:57 EDT
Looking at https://apps.fedoraproject.org/packages/qutebrowser/overview/ this should now be fixed at least in Rawhide?

I must be missing something though :) Looks like there are fc26/27/28 packages at https://apps.fedoraproject.org/packages/qutebrowser/builds/ but not on the overview page? Will those be updated as well?

(Keep in mind I have no idea how Fedora works exactly :D)
Comment 22 Timothée Floure 2017-11-03 15:56:57 EDT
I built the new package for f26/f27 and rawhide but there's still a few things I want to clarify with Tomas before pushing the new package to testing :
Comment 23 Timothée Floure 2017-11-03 16:09:35 EDT
(Woops, I didn't finish to write the last comment...)

- since qutebrowser >=1.0 will break the 'old' configs, I'm not sure about releasing for f26.
- There are a dependency issue on rawhide for some architectures
- A few questions about the packaging of Qt's binding for python3

He will be back by monday, so things will move next week :)
Comment 24 Upstream Release Monitoring 2017-11-06 19:24:23 EST
Latest upstream release: v1.0.3
Current version/release in rawhide: 1.0.2-1.fc28
URL: http://www.qutebrowser.org

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/9759/
Comment 25 Upstream Release Monitoring 2017-11-06 19:24:28 EST
Skipping the scratch build because an SRPM could not be built: ['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', u'/var/tmp/thn-MGaUo9/qutebrowser.spec'] returned 1: error: line 27: Unknown tag: Recommends:	python3-cssutils
Comment 26 Timothée Floure 2017-11-14 02:50:58 EST
Due to the new config system ignoring the old configuration, we won't release qutebrowser >= 1.0 for Fedora 26. However, we do not want to wait for 6 more months (F28) so we will release for F27 even if we're going to be a bit late.

An updated package for qutebrowser 1.0.3 has been submitted [0] to bodhi and should enter testing soon.

[0] https://bodhi.fedoraproject.org/updates/FEDORA-2017-28dcc5b3ae
Comment 27 Florian Bruhin 2017-11-14 03:00:47 EST
Thanks for the update! I think that makes sense.

If you have the time, can you maybe update to v0.11.1 for f26? Related changelogs:

https://github.com/qutebrowser/qutebrowser/releases/tag/v0.11.0
https://github.com/qutebrowser/qutebrowser/releases/tag/v0.11.1

v0.11.0 adds PyQt5.QtOpenGL and PyOpenGL dependencies when used with QtWebEngine, but since that's not the default and not easily switchable (only via a commandline switch), it's probably okay to ignore those.

It comes with some important improvements, such as protection for some phishing attacks (using punycode domains) and not posting crash reports to a public place anymore. On top of that, it fixes various crashes ;-)
Comment 28 Timothée Floure 2017-11-14 03:35:11 EST
(In reply to Florian Bruhin from comment #27)
> Thanks for the update! I think that makes sense.
> 
> If you have the time, can you maybe update to v0.11.1 for f26? Related
> changelogs:
> 
> https://github.com/qutebrowser/qutebrowser/releases/tag/v0.11.0
> https://github.com/qutebrowser/qutebrowser/releases/tag/v0.11.1
> 
> v0.11.0 adds PyQt5.QtOpenGL and PyOpenGL dependencies when used with
> QtWebEngine, but since that's not the default and not easily switchable
> (only via a commandline switch), it's probably okay to ignore those.
> 
> It comes with some important improvements, such as protection for some
> phishing attacks (using punycode domains) and not posting crash reports to a
> public place anymore. On top of that, it fixes various crashes ;-)

Yes, F26 only reached half of its life cycle : we can't ignore it. I move this issue to Bug 1512821 [0] since it doesn't concern the same Fedora version/ quetebrowser release.

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1512821
Comment 29 Tomas Orsava 2017-11-14 05:27:04 EST
Good work, Timothée!
Comment 30 Fedora Update System 2017-11-14 05:58:41 EST
qutebrowser-1.0.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-28dcc5b3ae
Comment 31 Timothée Floure 2017-11-15 02:01:38 EST
I found some typo in the weak dependencies of the package. I unpushed `1.0.3-1` from testing and submitted a new PR [0] for `1.0.3-2`.

It's going to take a few more days, sorry about that.

[0] http://pkgs.fedoraproject.org/rpms/qutebrowser/pull-request/3#
Comment 32 Fedora Update System 2017-11-15 07:58:46 EST
qutebrowser-1.0.3-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5918910b2c
Comment 33 Fedora Update System 2017-11-15 18:53:19 EST
qutebrowser-1.0.3-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5918910b2c
Comment 34 Fedora Update System 2017-11-28 18:49:08 EST
qutebrowser-1.0.3-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.