Bug 1467786 - OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was removed in master service env file on the second run
OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was removed in ma...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kenny Woodson
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 03:24 EDT by Gaoyun Pei
Modified: 2017-08-16 15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2017-07-05 03:24:06 EDT
Description of problem:
Re-run the installer on ocp-3.6 after a successful deployment( or at least master configuration was finished), after the second run, found OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was not shown in master service env file.
[root@qe-gpei-etcd-sc-master-1 ~]# cat /etc/sysconfig/atomic-openshift-master 
OPTIONS=--loglevel=5
CONFIG_FILE=/etc/origin/master/master-config.yaml
IMAGE_VERSION=v3.6.133

# Proxy configuration
# See https://docs.openshift.com/enterprise/latest/install_config/install/advanced_install.html#configuring-global-proxy
NO_PROXY=.cluster.local,qe-gpei-etcd-sc-master-1,172.30.0.0/16,10.128.0.0/14


This issue should also affect master scale-up, for new masters, they will also not have this line added in master service env files.


Version-Release number of selected component (if applicable):
openshift-ansible-3.6.133-1.git.0.950bb48.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. See Description

Actual results:


Expected results:


Additional info:
Comment 3 Johnny Liu 2017-07-07 07:18:37 EDT
Currently the latest puddle QE get is AtomicOpenShift/3.6/2017-07-07.2, but its openshift-ansible version openshift-ansible-3.6.126.14-1.git.0.efd80ab.el7, does not have this PR merged.
Comment 5 Gaoyun Pei 2017-07-10 04:11:11 EDT
Verify this bug with openshift-ansible-3.6.140-1.git.0.4a02427.el7.noarch

When re-run installer against an ocp-3.6 cluster, OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000 was not removed from master service env files.

For non-ha master env, it's still configured in /etc/sysconfig/atomic-openshift-master

For ha master env, it's still configured in /etc/sysconfig/atomic-openshift-master-api and /etc/sysconfig/atomic-openshift-master-controllers
Comment 7 Gaoyun Pei 2017-07-10 22:59:28 EDT
Move it to verified according to Comment 5
Comment 9 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.