Bug 1467820 - Change in method name in tempest/common broke cinder's internal tempest tests
Change in method name in tempest/common broke cinder's internal tempest tests
Status: CLOSED DUPLICATE of bug 1441228
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Prateek Arora
Martin Kopec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 04:47 EDT by Martin Schuppert
Modified: 2017-07-05 08:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-05 05:54:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1667448 None None None 2017-07-05 04:47 EDT
OpenStack gerrit 394588 None None None 2017-07-05 04:49 EDT

  None (edit)
Description Martin Schuppert 2017-07-05 04:47:32 EDT
Description of problem:

{0} setUpClass (cinder.tests.tempest.api.volume.test_volume_unicode.CinderUnicodeTest) [0.000000s] ... FAILED
Number of Tests that Ran 192
Number of Tests that Passed 190
Number of Tests that Failed 1
Number of Tests that Skipped 1
Failures/Skips in Test Run. Please review the json file attached
Error: tempest.api.volume.v2.test_volumes_list.VolumesV2ListTestJSON.test_volume_list_with_detail_param_marker[id-46eff077-100b-427f-914e-3db2abcdb7e2]   SKIP
Error: setUpClass (cinder.tests.tempest.api.volume.test_volume_unicode.CinderUnicodeTest)   FAIL
Reason of Failure:
========================================
_StringException: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 273, in setUpClass
    six.reraise(etype, value, trace)
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 266, in setUpClass
    cls.resource_setup()
  File "/usr/lib/python2.7/site-packages/cinder/tests/tempest/api/volume/test_volume_unicode.py", line 35, in resource_setup
    cls.volume = cls.create_volume_with_args(name=cls.volume_name)
  File "/usr/lib/python2.7/site-packages/cinder/tests/tempest/api/volume/test_volume_unicode.py", line 47, in create_volume_with_args
    waiters.wait_for_volume_resource_status(cls.volumes_client,
AttributeError: 'module' object has no attribute 'wait_for_volume_resource_status'

This was fixed upstream in 

https://bugs.launchpad.net/cinder/+bug/1667448
https://review.openstack.org/#/c/394588


Version-Release number of selected component (if applicable):
openstack-tempest-15.0.0-2.el7ost
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-05 04:49:09 EDT
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.
Comment 2 Prateek Arora 2017-07-05 05:25:30 EDT
Hello Martin

The bug has been fixed in cinder. I would check if the fix is backported to cinder and not I would do that.

Thanks and Regards
Prateek Arora
Comment 5 Prateek Arora 2017-07-05 05:54:32 EDT

*** This bug has been marked as a duplicate of bug 1441228 ***

Note You need to log in before you can comment on or make changes to this bug.