Bug 1467832 - backport "winbind request timeout" to samba-winbind-3.6
backport "winbind request timeout" to samba-winbind-3.6
Status: CLOSED DUPLICATE of bug 1467395
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba (Show other bugs)
6.8
Unspecified Linux
high Severity high
: rc
: 6.10
Assigned To: Andreas Schneider
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 05:20 EDT by Dariusz Wojewódzki
Modified: 2017-07-18 05:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 05:14:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dariusz Wojewódzki 2017-07-05 05:20:01 EDT
Description of problem:
I would like to request the backport of the following fix to samba-winbind-3.6 as per 
https://attachments.samba.org/attachment.cgi?id=10128
and https://bugzilla.samba.org/show_bug.cgi?id=3204


Version-Release number of selected component (if applicable):
This is missed for the RHEL6 branch.
Please asses the possibility to integrate patch on RHEL 6.X Line.

How reproducible:


Steps to Reproduce:
(for unknown reason) winbind __does not close sockets__
Here what scenario looks like (on actual production system, as mentioned before we are not able to reproduce it):

At some point in time following messages appears (this looks like random, no apparent issues are reported by OS before):
May  1 11:03:27 zc01.zone1 winbindd[5556]: [2017/05/01 11:03:27.380063,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 11:03:27 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 11:03:27 zc01.zone1 winbindd[5556]: [2017/05/01 11:03:27.388117,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 11:03:27 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 11:03:32 zc01.zone1 winbindd[5556]: [2017/05/01 11:03:32.119143,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 11:03:32 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 11:03:32 zc01.zone1 winbindd[5556]: [2017/05/01 11:03:32.119528,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 11:03:32 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
(...)
Winbind will stay at this state for some time, but after an hour or so process runs out of descriptors and message flood begins (this means like 10000+ entries/s), with following logs:

May  1 12:19:31 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 12:19:32 zc01.zone1 winbindd[5556]: [2017/05/01 12:19:32.468367,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 12:19:32 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 12:19:32 zc01.zone1 winbindd[5556]: [2017/05/01 12:19:32.468437,  0] winbindd/winbindd.c:817(new_connection)
May  1 12:19:32 zc01.zone1 winbindd[5556]:   Faild to accept socket - Too many open files
May  1 12:19:32 zc01.zone1 winbindd[5556]: [2017/05/01 12:19:32.468608,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 12:19:32 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 12:19:32 zc01.zone1 winbindd[5556]: [2017/05/01 12:19:32.468630,  0] winbindd/winbindd.c:817(new_connection)
May  1 12:19:32 zc01.zone1 winbindd[5556]:   Faild to accept socket - Too many open files
May  1 12:19:32 zc01.zone1 winbindd[5556]: [2017/05/01 12:19:32.468685,  0] winbindd/winbindd.c:975(winbindd_listen_fde_handler)
May  1 12:19:32 zc01.zone1 winbindd[5556]:   winbindd: Exceeding 200 client connections, no idle connection found
May  1 12:19:32 zc01.zone1 winbindd[5556]: [2017/05/01 12:19:32.468704,  0] winbindd/winbindd.c:817(new_connection)
May  1 12:19:32 zc01.zone1 winbindd[5556]:   Faild to accept socket - Too many open files


Actual results:
This of course provides huge impact on I/O, /var/log gets full in the matter of minutes and process itself eating up CPU making server so busy it's impossible to login on console or ssh. To recover the server you need to power-cycle & do some clean up on /var/log.


Expected results:


Additional info:
Comment 3 Andreas Schneider 2017-07-18 05:14:01 EDT

*** This bug has been marked as a duplicate of bug 1467395 ***

Note You need to log in before you can comment on or make changes to this bug.